Bug 663776 - [abrt] evolution-2.28.3-10.el6: ORBit_RootObject_duplicate: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-2.28.3-10.el6: ORBit_RootObject_duplicate: Process /usr/bin/...
Keywords:
Status: CLOSED DUPLICATE of bug 660356
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution
Version: 6.0
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: abrt_hash:c9321574c0d35af888850a6565c...
: 669761 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-16 19:45 UTC by Marc Milgram
Modified: 2011-01-18 21:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-17 15:17:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: backtrace (61.82 KB, text/plain)
2010-12-16 19:45 UTC, Marc Milgram
no flags Details

Description Marc Milgram 2010-12-16 19:45:27 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: evolution
component: evolution
crash_function: ORBit_RootObject_duplicate
executable: /usr/bin/evolution
kernel: 2.6.32-71.el6.x86_64
package: evolution-2.28.3-10.el6
rating: 4
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux Workstation release 6.0 (Santiago)
time: 1292528497
uid: 13847

How to reproduce
-----
1. Configure evolution with several webcal calendars (the more the better)
2. During a meeting, switch to calendar mode
3. restart evolution and evolution-data-server
4. Immediately, unselect a calendar (so it doesn't show up any more).

Comment 1 Marc Milgram 2010-12-16 19:45:30 UTC
Created attachment 469206 [details]
File: backtrace

Comment 3 Milan Crha 2010-12-17 08:28:44 UTC
Thanks for a bug report. I believe this happened just as you described, the calendar, when unchecked, didn't clear all parts of it, namely the ORBit part, thus when it received asynchronous reply about new objects added, then it was operating on already freed memory (the 0xaaaaaaaaaaaaa pointer). Maybe there is missing some signal disconnection, though the question is where there, because in the below backtrace is only the very bottom, the main.c, part from evolution, the rest is from other libraries.


#0  0x000000301c62edb0 in ORBit_RootObject_duplicate (obj=0xaaaaaaaaaaaaaaaa)
    at orbit-object.c:125
#1  0x000000301c63fcbf in ORBit_POAObject_handle_request (
    pobj=0x7f8b980061b0, opname=0x7f8bb80398bc "notifyObjectsAdded", 
    ret=<value optimized out>, args=<value optimized out>, ctx=0x0, 
    recv_buffer=0x7f8bb800aa40, ev=<value optimized out>) at poa.c:1228
#2  0x000000301c6404a1 in ORBit_POAObject_invoke_incoming_request (
    pobj=0x7f8b980061b0, recv_buffer=0x7f8bb800aa40, opt_ev=0x0) at poa.c:1427
#3  0x000000301c6292cc in giop_thread_queue_process (tdata=0x1d12280)
    at giop.c:792
#4  0x000000301c629458 in giop_mainloop_handle_input (
    source=<value optimized out>, condition=<value optimized out>, 
    data=<value optimized out>) at giop.c:482
#5  0x0000003013a38f0e in g_main_dispatch (context=0x1ce93f0) at gmain.c:1960
#6  IA__g_main_context_dispatch (context=0x1ce93f0) at gmain.c:2513
#7  0x0000003013a3c938 in g_main_context_iterate (context=0x1ce93f0, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2591
#8  0x0000003013a3cd55 in IA__g_main_loop_run (loop=0x1d59ff0) at gmain.c:2799
#9  0x0000003024e2d106 in bonobo_main () at bonobo-main.c:311
#10 0x000000000041569a in main (...) at main.c:732

Comment 5 Jacob Hunt 2011-01-06 22:48:34 UTC
Package: evolution-2.28.3-10.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Workstation release 6.0 (Santiago)


How to reproduce
-----
1.  Evolution was left open for a couple of hours and when I clicked in the main window, the entire application crashed
.


Comment
-----
evolution-2.28.3-10.el6.x86_64
evolution-data-server-devel-2.28.3-10.el6.x86_64
evolution-data-server-debuginfo-2.28.3-10.el6.x86_64
evolution-mapi-0.28.3-6.el6.x86_64
evolution-data-server-2.28.3-10.el6.x86_64
evolution-data-server-doc-2.28.3-10.el6.noarch
evolution-help-2.28.3-10.el6.noarch

Comment 6 Milan Crha 2011-01-17 10:13:26 UTC
I'm thinking how much this is related to the upstream bug [1]. I'll try to reproduce it here and see what I'll find.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=627788

Comment 7 Milan Crha 2011-01-17 10:57:58 UTC
*** Bug 669761 has been marked as a duplicate of this bug. ***

Comment 8 Milan Crha 2011-01-17 15:17:13 UTC
(In reply to comment #6)
> I'm thinking how much this is related to the upstream bug [1]. I'll try to
> reproduce it here and see what I'll find.
> 
> [1] https://bugzilla.gnome.org/show_bug.cgi?id=627788

Ouch, my fault, I'm sorry, this is related to bug #660356, it's the same issue, only other place of the crash, few steps earlier than in that bug.
I'm marking this as a duplicate of that bug.

*** This bug has been marked as a duplicate of bug 660356 ***


Note You need to log in before you can comment on or make changes to this bug.