Bug 66378 - Up2date bomb out with traceback
Summary: Up2date bomb out with traceback
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-09 07:03 UTC by Milan Kerslager
Modified: 2015-01-07 23:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 22:10:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2002-06-09 07:03:42 UTC
The system was fully updated (up2date-2.7.61-7.x.2). I've got this traceback:

Traceback (innermost last):
  File "/usr/sbin/up2date", line 1137, in ?
    main()
  File "/usr/sbin/up2date", line 250, in main
    up2date.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2date.py", line 541, in updateLoginInfo
    loginInfo = login()
  File "/usr/share/rhn/up2date_client/up2date.py", line 472, in login
    loginInfo = doCall(server.up2date.login, systemId)
  File "/usr/share/rhn/up2date_client/up2date.py", line 411, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 689, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 746, in __request
    self.__protocol
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 652, in request
    return self.parse_response(fd)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 667, in 
parse_response
    return u.close()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 366, in close
    raise apply(Fault, (), self._stack[0])
xmlrpclib.Fault: <Fault -51 """
Error Message:
    Free service limited due to high load, please try again later (server 
1000778366)
Error Class Code: 51
Error Class Info:
     Due to extremely high traffic, access to Red Hat Network is currently
     limited to subscription customers.  Please try again later.  If you
     would like to become a subscription customer, go to
     https://rhn.redhat.com/preview/priority_service.pxt for more information.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
""">

Error Message:
    Free service limited due to high load, please try again later (server 
1000778366)
Error Class Code: 51
Error Class Info:
     Due to extremely high traffic, access to Red Hat Network is currently
     limited to subscription customers.  Please try again later.  If you
     would like to become a subscription customer, go to
     https://rhn.redhat.com/preview/priority_service.pxt for more information.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Comment 1 Jay Turner 2002-06-10 12:12:13 UTC
This is the message that you get when our servers are fully loaded and therefore
cannot serve any additional requests.

This pretty much explains it:
Due to extremely high traffic, access to Red Hat Network is currently
     limited to subscription customers.  Please try again later.  If you
     would like to become a subscription customer, go to
     https://rhn.redhat.com/preview/priority_service.pxt for more information.

Comment 2 Milan Kerslager 2002-06-10 12:23:21 UTC
Did you see the traceback? Don't tell me that this is normal to make an
application (and as I read, your CEO told that this IS what make money for RH)
that bomb out due to "High server load" message.

I did this as I'm pretty sure that this is mistake in your code that should be
fixed. I gave you a traceback so read them and fix your Python code, dear folks.

Are you kidding or what?

Comment 3 Jay Turner 2002-06-10 13:05:34 UTC
Indeed this is what's supposed to happen.  You are attempting to log into the
site with a free account.  That is an account for which you have paid nothing. 
At high demand times, we limit the number of free subscribers that can access
the site in order to preserve bandwidth and service level for the customers who
are paying for the service.  Granted a traceback isn't the most kind way to
message that to the user, and we have fixed this up quite a lot in latest
versions of the client, but we have to be able to pass the message to anyone no
matter what client version they are running.  So, just as the message says, if
you would like to avoid this message in the future, just visit the site listed
and purchase an entitlement.

Comment 4 Milan Kerslager 2002-06-10 13:43:13 UTC
You don't underestand me. What is reported is traceback not "Service disabled by
high load".

Do you trying to tell me that traceback is normal way to pass messages to
anonymous user? Should me and and hundred people on the world see that you are
bad programmers in RH? How we will trust that when we will pay money to RH, your
service will be bug-free and tools will be fixed ASAP?

This bug is in up2date code for long time. I saw it many times ago (and other
users too). This report is here because I believe that when I report it, code
will be fixed in the next release.

I know that I can pay for service to RH and I did. Please fix your code and
don't talk about what is not Bugzilla for (with reported traceback).

Comment 5 Jay Turner 2002-06-10 13:56:45 UTC
Indeed the traceback is that service was disabled because of high load:

Error Message:
    Free service limited due to high load, please try again later (server 
1000778366)
Error Class Code: 51
Error Class Info:
     Due to extremely high traffic, access to Red Hat Network is currently
     limited to subscription customers.  Please try again later.  If you
     would like to become a subscription customer, go to
     https://rhn.redhat.com/preview/priority_service.pxt for more information.

"Free service limited due to high load"  That pretty much says it.  As for this
being a bug, it isn't.  We report an error to the client via xmlrpc.  The error
is that due to high load, we are not allowing free connections.  This is how it
is supposed to work and there's no code to fix.  There is not a bug here. 
Closing again with that resolution.

Comment 6 Milan Kerslager 2002-06-10 14:20:27 UTC
Traceback is because you have a bug in up2date program.

The traceback did not appear everytime. I ran up2date few times with same
traceback and few minutes later and there was no traceback, only message ("Due
to extremely blah blah") was printed on the screen.

It seems that up2date bomb out with traceback when server reply with
non-standard or broken string.

Comment 7 Adrian Likins 2002-06-13 20:51:28 UTC
Interesting. Looks like the exception doesnt get caught
if you specify "-p", or "--showall".

Should be fixed in the next release.


Note You need to log in before you can comment on or make changes to this bug.