Bug 663820 - Unable to extend DHCP timeout
Unable to extend DHCP timeout
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.0
i686 Linux
medium Severity high
: rc
: ---
Assigned To: Dan Williams
Desktop QE
:
Depends On:
Blocks: 669019 744956 756082 769145
  Show dependency treegraph
 
Reported: 2010-12-16 18:02 EST by John Newbigin
Modified: 2012-06-20 09:41 EDT (History)
7 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-22.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 769145 (view as bug list)
Environment:
Last Closed: 2012-06-20 09:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backport of the previous patch for RHEL-6.3 (5.93 KB, patch)
2012-03-02 07:54 EST, Jirka Klimes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 64543 None None None Never

  None (edit)
Description John Newbigin 2010-12-16 18:02:15 EST
Description of problem:
There does not seem to be any way of extending the DHCP timeout to more than 45 seconds. This prevents installation via PXE.

Even if the dhclient timeout is extended, NetworkManager will kill it before the address is obtained.

This is (as always) a problem with a Cisco switch which takes 60 seconds to start forwarding traffic. I believe this is related to the etherchannel bonding rather than portfast but either way, altering the switch config is not permitted.

DHCP would work perfectly well if the timeout could be extended.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Could be reproduced by turning off the DHCP server at the right time and then turning it back on 60 seconds later.
2.
3.
  
Actual results:
The message
"There was an error configuring your network interface."
is shown and using the retry button only produces the same results.

Expected results:
Some combination of nicdelay and dhcptimeout would allow the DHCP timeout to be set to 120 seconds.

Even better, keep DHCP running in the background rather than giving up and don't keep taking the interface up and down.

Or, in the config dialog, allow the timout to be altered.

Additional info:
This might be relevant
http://old.nabble.com/DHCP-timeout-is-too-short-for-this-college-network-td27105772.html
Comment 2 RHEL Product and Program Management 2011-04-03 21:54:56 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-10-07 11:59:00 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 13 errata-xmlrpc 2012-06-20 09:41:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0832.html

Note You need to log in before you can comment on or make changes to this bug.