Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 663845 - [lokalize] Editing with Backspace and moving forward create junk data in Translation field
Summary: [lokalize] Editing with Backspace and moving forward create junk data in Tran...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdesdk
Version: 14
Hardware: Unspecified
OS: Linux
low
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-17 02:53 UTC by A S Alam
Modified: 2013-10-04 12:22 UTC (History)
12 users (show)

Fixed In Version: qt-4.7.1-17.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-26 03:56:17 UTC
Type: ---


Attachments (Terms of Use)
Video/OGG for Problem (262.20 KB, video/x-theora+ogg)
2010-12-17 02:53 UTC, A S Alam
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-15857 0 None None None Never

Description A S Alam 2010-12-17 02:53:12 UTC
Created attachment 469262 [details]
Video/OGG for Problem

Description of problem:
While using lokalize for translation, if edit some text (preferably with tag, problem exist without tab, but not easy to reproduce), and move forward and just return back, check Text in string. Many more characters are just inserted automatically.

Version-Release number of selected component (if applicable):
qt-4.7.1-5.fc14.x86_64
kdesdk-4.5.4-1.fc14.x86_64


How reproducible:
Random

Steps to Reproduce:
1. run lokalize with translation file (PO file [1])
2. input something in local language (other than English)
3. Use BackSpace to delete some (not all)
5. Page Down (Move to next string)
6. Page Up (Move back to original String
  
Actual results:
Junk data inserted in text field automatically, which is not typed

Expected results:
Only Text should be there, which is typed, works fine with BackSpace

Additional info:
Need to check https://bugzilla.redhat.com/show_bug.cgi?id=660028 bug fix, it there is regression.

[1] http://websvn.kde.org/*checkout*/trunk/l10n-kde4/pa/messages/kdebase/kcmbell.po

Comment 1 A S Alam 2010-12-19 05:03:52 UTC
It is confirmed that this issue was not present with following qt:
qt-4.7.0-3.fc14.x86_64

Bug #660028 ([lokalize] Application Crash with Backspace (qt-4.7.1 bug)fix can be reason of regression.

Increase severity because application is still unusable for translation.

Comment 2 A S Alam 2011-01-13 19:13:12 UTC
Not sure how, but rawhide this problem is not there
--
qt-4.7.1-9.fc15.i686.rpm 
kdesdk-4.5.95-1.fc15.x86_64.rpm 
---

tried to use qt-4.7.1-9.fc14 (from koji), but it was not working on fedora 14

Comment 3 Mario Santagiuliana 2011-01-27 23:10:21 UTC
Problem exist here on my fedora box too:
$ rpm -q qt
qt-4.7.1-7.fc14.x86_64
$ rpm -q kdesdk
kdesdk-4.5.5-1.fc14.x86_64

Comment 4 Fedora Update System 2011-01-27 23:22:39 UTC
qt-4.7.1-13.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.1-13.fc14

Comment 5 Rex Dieter 2011-01-27 23:27:11 UTC
Upstream commit included here,
http://qt.gitorious.org/qt/qt/commit/34c297faca93e1286573b2a01127e4e7af00aff2

Comment 6 Mario Santagiuliana 2011-01-27 23:40:05 UTC
It is something crazy :) I just update my qt library from updates-testing. The problem seem resolve. And now Fedora Update System tell us that qt was push on update repo ahahah I should wait 15 minute :)

OK, I need to do more test. For now no problmes.

Comment 7 Kevin Kofler 2011-01-27 23:52:25 UTC
Uh no, it hasn't been pushed as an official update yet. The automated message from our update system only says that it has been submitted for updates-testing (again; it was edited since the previous testing push).

Comment 8 Mario Santagiuliana 2011-01-27 23:56:20 UTC
No?...uh excuse me...I don't undestand "has been submitted as an update for Fedora 14".
Ok, now I have:
$ rpm -q qt
qt-4.7.1-13.fc14.x86_64
qt-4.7.1-13.fc14.i686 <---needed for other my 32 bit application

Lokalize work without problem, for now.

Comment 9 Kevin Kofler 2011-01-28 00:06:59 UTC
"Submitted" significa soltanto che l'aggiornamento è stato inserito nel sistema. Quando l'aggiornamento è disponibile per gli utenti come aggiornamento ufficiale, il commento dice "has been pushed to the Fedora 14 stable repository."

(I hope that clears up the misunderstanding.)

Comment 10 Fedora Update System 2011-02-13 08:48:33 UTC
qt-4.7.1-15.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-15.fc14

Comment 11 Fedora Update System 2011-02-16 19:19:32 UTC
qt-4.7.1-17.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-16.fc14

Comment 12 Fedora Update System 2011-02-26 03:55:48 UTC
qt-4.7.1-17.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Red Hat Bugzilla 2013-10-04 00:19:46 UTC
Removing external tracker bug with the id '15857' as it is not valid for this tracker


Note You need to log in before you can comment on or make changes to this bug.