Bug 66385 - sndconfig with VIA VT8233 AC97 hangs
sndconfig with VIA VT8233 AC97 hangs
Status: CLOSED DUPLICATE of bug 54905
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-09 11:38 EDT by Andrew Jones
Modified: 2013-07-02 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 11:46:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Jones 2002-06-09 11:38:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
The exact string that sndconfig returns is VIA Technologies|VT8233 AC97 Audio
Controller. This is correct (as far as i know), and is the on-board sound for
the Spacewalker KT266A motherboard. After detecting this, it says it will try to
play a sound, then it hangs trying. I hear nothing, and the output of "ps" shows
me that sox is trying to do something, but sndconfig doesn't do anything else.
^C kills it as expected. I have tried this in a terminal window under X, and
from single user mode, if that makes any difference.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run sndconfig with the proper hardware.
2.
3.
	

Actual Results:  sndconfig hangs.

Expected Results:  It should either play something that i can hear, or it should
fail in some way. I would expect that it plays the sample and comes back to ask
me if i had heard it properly.

Additional info:
Comment 1 Andrew Jones 2002-06-09 11:43:34 EDT
If it helps, the following three lines appear in the system log:
kernel: Via 686a audio driver 1.9.1
kernel: ac97_codec: AC97 Audio codec, id: 0x4943:0x4511 (ICE1232)
kernel: via82cxxx: board #1 at 0xE800, IRQ 5
Comment 2 Bill Nottingham 2002-06-12 02:06:30 EDT
If it *hangs*, that implies a driver issue.
Comment 3 Davide Bolcioni 2002-08-18 11:47:56 EDT
In my experience, the problem might be the volume and/or the mixer settings.
That is, the sound is played but the volume (either in the mixer or in the
loudspeaker)
is too low.
Comment 4 Andrew Jones 2002-08-18 13:03:21 EDT
If that were the case, then i would expect that sndconfig would return at some
point and ask if i had heard the sound. Certainly used to work that way.
sndconfig never returned and had to be killed with ^C

As long as we're on the topic, 2.4.18-5 now claims that the sound device is not
there, although it is onboard. sndconfig detects the sound controller, just as
it did in previous versions, but when it tries to play a sample sound, it gives
me the error:

/lib/modules/2.4.18-5/kernel/drivers/sound/via82cxxx_audio.o: init_module: No
such device

...and further insmod errors that all stem from that first error.
Comment 5 Jeff Garzik 2002-10-21 11:36:32 EDT

*** This bug has been marked as a duplicate of 54905 ***

Note You need to log in before you can comment on or make changes to this bug.