Bug 66390 - i810 with 4MB no longer handles 1280x1024x16 after upgrade from 7.2
i810 with 4MB no longer handles 1280x1024x16 after upgrade from 7.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82787
  Show dependency treegraph
 
Reported: 2002-06-09 15:57 EDT by Max Rible
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 10:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log (26.26 KB, text/plain)
2002-06-09 15:58 EDT, Max Rible
no flags Details
XF86Config-4 (3.18 KB, text/plain)
2002-06-09 15:59 EDT, Max Rible
no flags Details
Successful XF86Config for 1280x1024x8bit screen (3.60 KB, text/plain)
2002-11-09 19:32 EST, Max Rible
no flags Details
Successful XFree86.0.log output for starting in 1280x1024x8bit (31.22 KB, text/plain)
2002-11-09 19:33 EST, Max Rible
no flags Details
Unsuccessful XF86Config for 1280x1024x16bit (3.60 KB, text/plain)
2002-11-09 19:34 EST, Max Rible
no flags Details
Unsuccessful XFree86.0.log for starting in 1280x1024x16bit (29.47 KB, text/plain)
2002-11-09 19:34 EST, Max Rible
no flags Details

  None (edit)
Description Max Rible 2002-06-09 15:57:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
Under Red Hat Linux 7.2, my system (1GHz Pentium Coppermine with 256MB RAM, 30GB
disk, Intel 82810E DC-133 Chipset Graphics Controller (rev 03) (prog-if 00
[VGA]) with 4MB RAM) was able to run in 1280x1024 mode with 16-bit color.  When
I upgraded to Red Hat 7.3, XFree86 failed to start, and I had to take the system
down to init 3 to turn off the flailing kdm and run Xconfigurator. 
Xconfigurator was able to get 1280x1024x8 or 1024x768x16 working, and if I lied
and said I had 8MB of video RAM instead of 4 I could bring up a fine-looking
1280x1024x16 screen with no working mouse or keyboard driver, but I couldn't get
1280x1024x16 back.

Version-Release number of selected component (if applicable):
"rpm -q XFree86" reports XFree86-4.2.0-8.

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 7.2 on an i810 system with 4MB video RAM.
2. Run Xconfigurator, set to 1280x1024x16bit, 4MB RAM.
3. Upgrade to Red Hat Linux 7.3.

Actual Results:  When the system came up, kdm began flailing because XFree86 was
failing to start properly.

Expected Results:  The system should have come up in 1280x1024x16 mode.

Additional info:

I will attach my XFree86.0.log and XF86Config-4.
Comment 1 Max Rible 2002-06-09 15:58:37 EDT
Created attachment 60225 [details]
XFree86.0.log
Comment 2 Max Rible 2002-06-09 15:59:30 EDT
Created attachment 60226 [details]
XF86Config-4
Comment 3 Mike A. Harris 2002-06-09 22:44:16 EDT
Are you using our kernel, or a self-compiled one?
Please attach the output of "uname -a" and "rpm -qa | grep kernel".

It appears from the log that your machine is not able to get AGP memory,
and that is causing it to fail.

(II) I810(0): [drm] created "i810" driver at busid "PCI:0:1:0"
(II) I810(0): [drm] added 8192 byte SAREA at 0xd09d3000
(II) I810(0): [drm] mapped SAREA 0xd09d3000 to 0x40014000
(II) I810(0): [drm] framebuffer handle = 0xe8000000
(II) I810(0): [drm] added 1 reserved context for kernel
(II) I810(0): [drm] Registers = 0xeff80000
(II) I810(0): [agp] dcacheHandle : (nil)
(II) I810(0): [agp] GART: no dcache memory found
(II) I810(0): [agp] Bound backbuffer memory
(II) I810(0): [agp] Bound depthbuffer memory
(EE) I810(0): [agp] drmAgpAlloc failed
(EE) I810(0): [drm] failed to remove DRM signal handler
(II) I810(0): [drm] removed 1 reserved context for kernel
DRIUnlock called when not locked
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xd09d3000 at 0x40014000
(==) I810(0): Write-combining range (0xe8000000,0x4000000)
(II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(II) I810(0): Setting dot clock to 108.0 MHz [ 0x10 0x2 0x20 ] [ 18 4 2 ]
(II) I810(0): chose watermark 0x22210000: (tab.freq 108.0)
(WW) I810(0): xf86AllocateGARTMemory: allocation of 1024 pages failed
	(Cannot allocate memory)
(II) I810(0): No physical memory available for 4194304 bytes of DCACHE
(II) I810(0): Adding 0 scanlines for pixmap caching
(EE) I810(0): Ring buffer allocation failed

Please also check your CMOS settings to ensure adequate memory is assigned
to video adaptor via AGP.

Comment 4 Max Rible 2002-06-10 00:16:59 EDT
This happens with kernel-2.4.18-3 (installed with 7.3) and kernel-2.4.18-4
(provided by up2date).  agpgart is apparently loaded, according to lsmod.  I
haven't changed the CMOS settings from the ones that worked under 7.2, but I'll
recheck.

diogenes% uname -a
Linux diogenes 2.4.18-4 #1 Thu May 2 18:47:38 EDT 2002 i686 unknown

diogenes% rpm -qa | grep kernel
kernel-source-2.4.18-4
kernel-doc-2.4.18-4
kernel-2.4.18-3
kernel-2.4.18-4

diogenes% lsmod
Module                  Size  Used by    Not tainted
sd_mod                 12928   0 (autoclean)
i810_audio             23008   1 (autoclean)
ac97_codec             11904   0 (autoclean) [i810_audio]
soundcore               6692   2 (autoclean) [i810_audio]
agpgart                39488   4 (autoclean)
nfsd                   76160   8 (autoclean)
lockd                  56736   1 (autoclean) [nfsd]
sunrpc                 75764   1 (autoclean) [nfsd lockd]
parport_pc             18724   1 (autoclean)
lp                      8864   0 (autoclean)
parport                34208   1 (autoclean) [parport_pc lp]
autofs                 12164   0 (autoclean) (unused)
irlan                  26092   0 (unused)
irda                  117196   0 [irlan]
8139too                16448   1
mii                     2408   0 [8139too]
ipchains               43560  12
ide-cd                 30272   0 (autoclean)
cdrom                  32192   0 (autoclean) [ide-cd]
usb-storage            58156   0
scsi_mod              108608   2 [sd_mod usb-storage]
usb-uhci               24484   0 (unused)
usbcore                73152   1 [usb-storage usb-uhci]
ext3                   67136   7
jbd                    49464   7 [ext3]

Thank you for your prompt response!
Comment 5 Max Rible 2002-06-10 00:57:25 EDT
My BIOS has no provisions for changing any parameters involving the AGP.
Comment 6 Mike A. Harris 2002-06-20 06:59:00 EDT
Please run:

rpm -q --qf '%{name}-%{version}-%{release} %{arch}\n' $(rpm -qa |grep kernel)

Comment 7 Max Rible 2002-06-20 16:28:26 EDT
Had to switch to bash...

[max@diogenes max]$ rpm -q --qf '%{name}-%{version}-%{release} %{arch}\n' $(rpm
-qa |grep kernel)
kernel-source-2.4.18-4 i386
kernel-doc-2.4.18-4 i386
kernel-2.4.18-3 i686
kernel-2.4.18-4 i686
Comment 8 Max Rible 2002-10-05 19:15:41 EDT
Upgrading to Red Hat 8.0 hasn't made a difference.

diogenes% rpm -qa | grep kernel | xargs -ifoo rpm -q --qf
'%{name}-%{version}-%{release} %{arch}\n' foo
kernel-doc-2.4.18-14 i386
alsa-kernel-0.9.0rc3-fr11_2.4.18_14 i686
kernel-2.4.18-14 i686
kernel-source-2.4.18-14 i386

diogenes% lsmod
Module                  Size  Used by    Not tainted
ircomm-tty             25824   0 (autoclean)
ircomm                 10952   0 (autoclean) [ircomm-tty]
ide-cd                 33608   0 (autoclean)
cdrom                  33696   0 (autoclean) [ide-cd]
snd-pcm-oss            44228   0 (autoclean)
snd-mixer-oss          13496   1 (autoclean) [snd-pcm-oss]
snd-intel8x0           15168   2 (autoclean)
snd-ac97-codec         34404   0 (autoclean) [snd-intel8x0]
snd-pcm                83264   1 (autoclean) [snd-pcm-oss snd-intel8x0]
snd-timer              15336   0 (autoclean) [snd-pcm]
snd-mpu401-uart         4796   0 (autoclean) [snd-intel8x0]
snd-rawmidi            18912   0 (autoclean) [snd-mpu401-uart]
snd-seq-device          6176   0 (autoclean) [snd-rawmidi]
snd                    40044   3 (autoclean) [snd-pcm-oss snd-mixer-oss
snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi
snd-seq-device]
soundcore               6532   3 (autoclean) [snd]
agpgart                43072   4 (autoclean)
binfmt_misc             7524   1
nfsd                   79920   8 (autoclean)
lockd                  58064   1 (autoclean) [nfsd]
sunrpc                 79324   1 (autoclean) [nfsd lockd]
parport_pc             19108   1 (autoclean)
lp                      8996   0 (autoclean)
parport                37152   1 (autoclean) [parport_pc lp]
irtty                   8032   2 (autoclean)
irda                  121968   1 (autoclean) [ircomm-tty ircomm irtty]
autofs                 13348   0 (autoclean) (unused)
8139too                17704   1
mii                     2156   0 [8139too]
ipchains               42440  10
mousedev                5524   1
keybdev                 2976   0 (unused)
hid                    22244   0 (unused)
input                   5888   0 [mousedev keybdev hid]
usb-uhci               26188   0 (unused)
usbcore                77024   1 [snd hid usb-uhci]
ext3                   70368   7
jbd                    52212   7 [ext3]
Comment 9 Mike A. Harris 2002-11-07 06:56:07 EST
Please try the latest developmental XFree86 CVS packages from
ftp://people.redhat.com/mharris/testing/live-grenades/XFree86

This should solve the problem you're having.  Setting bug state
to MODIFIED.  If the above package works as expected, please close
bug as RAWHIDE, or indicate that it is working now.  Otherwise
if the problem continues, please set to ASSIGNED.
Comment 10 Max Rible 2002-11-09 19:31:09 EST
I loaded up the packages as requested.  (Colormaps are now really freaky in
1280x1024x8bit, by the way.  emacs, bugzilla, and console all look okay when I'm
focused on them, evolution looks weird even when it has focus.)  Installation
(rpm -Uvh *.rpm) generated only one error message:
/var/tmp/rpm-tmp.99506: line 1: xftcache: command not found

The system still works in 1280x1024x8 (with the aforementioned colormap
freakiness) but fails to do so in 1280x1024x15 or 1280x1024x16.  I will attach
the files XF86Config.8bit and XFree86.0.log.8bit to show a successful X startup
and XF86Config.16bit and XFree86.0.log.16bit to show an unsuccessful one.
Comment 11 Max Rible 2002-11-09 19:32:28 EST
Created attachment 84384 [details]
Successful XF86Config for 1280x1024x8bit screen
Comment 12 Max Rible 2002-11-09 19:33:21 EST
Created attachment 84385 [details]
Successful XFree86.0.log output for starting in 1280x1024x8bit
Comment 13 Max Rible 2002-11-09 19:34:08 EST
Created attachment 84386 [details]
Unsuccessful XF86Config for 1280x1024x16bit
Comment 14 Max Rible 2002-11-09 19:34:54 EST
Created attachment 84387 [details]
Unsuccessful XFree86.0.log for starting in 1280x1024x16bit
Comment 15 Max Rible 2002-11-09 19:37:17 EST
Thank you for all your efforts-- I really appreciate this.
Comment 16 Max Rible 2002-11-30 18:18:33 EST
I have found a rather peculiar workaround.  I'm lying to the system about its
configuration.

Last time I tried this stunt was under Red Hat 7.3, and it failed miserably, as
documented above.

Lying to Red Hat 8.0 is *much* more effective.  I've got antialiased fonts
running now, and the xft mozilla 1.2 running just fine.  I've got a system
uptime of 7 days without any odd behaviors.

It's not a fix, but at least it gets the job done.  I hope that sheds some light
on the matter.
Comment 17 Mike A. Harris 2004-01-10 10:41:58 EST
Red Hat Linux 7.x and 8.0 are no longer supported by Red Hat.  Please
upgrade to one of the following OS releases and see if you still
encounter this problem:

- Red Hat Linux 9
- Red Hat Enterprise Linux (version 3)
- Fedora Core 1

Ensure that your system then has all updates installed which have
been released by Red Hat since the initial release of the OS version
that you are using, and that you've rebooted your system into the
newest Red Hat kernel.  Also make sure that you are not running
any 3rd party kernel modules or video drivers.  If the problem still
exists in one of the above OS releases under these circumstances,
please read the i810 manpage, and see if any of the options it
describes might be relevant to the problem you are observing.  After
experimenting with any useful options, if the problem still exists,
please file a new bug report in bugzilla and attach all relevant
configuration details, etc. as in this report.  You may also want
to file a bug report upstream to XFree86.org in their bugzilla,
located at:  http://bugs.xfree86.org

Closing bug WONTFIX currently, as this OS release is no longer
supported, and it isn't known wether the problem occurs under
a supported OS release yet or not.

Note You need to log in before you can comment on or make changes to this bug.