Bug 66391 - ISDN driver not loaded by boot script
ISDN driver not loaded by boot script
Product: Red Hat Linux
Classification: Retired
Component: isdn4k-utils (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-06-09 16:53 EDT by Stefan Frings
Modified: 2006-08-04 16:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-04 16:22:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stefan Frings 2002-06-09 16:53:03 EDT
Description of Problem: 
The script /etc/init.d/isdn does not load my ISDN drivers. 
Version-Release number of selected component (if applicable): 
From RedHat 7.3, no version number in the script. 
How Reproducible: 
Configure an AVM Fritz Card PCI Version 2 with the Internet Configuration 
Wizard. Activate the device and test the Connection. Then reboot Linux and 
check the modules with lsmod. There are no ISDN drivers. Run "/etc/init.d/isdn 
start" and you can see no mess about success or failure. Check again the 
modules. there are no ISDN drivers. 
Additional Information: 
The file content of /etc/sysconfig/isdncard is: 
NAME="AVM PCI (Fritz!PCI v2)" 
The script /etc/init.d/isdn thinks that this is an ISDN card: 
# check PCMCIA 
if [ "$RESOURCES" = "NONE" ] ; then 
I commented these lines out and now my ISDN drivers are correctly loaded. My 
solution is quick dirty. PCMCIA users need another solution. Maybe it is a 
better idea to modify the Internet Configuration Wizard to set the variable 
RESOURCES to "" instead of NONE. 
I did not register my product but I hope you will fix this bug in the next 
version and send me a short feedback. 
Comment 1 Ngo Than 2002-06-10 11:41:11 EDT
The isdn cript is correct, problem is that your isdn config file looks strange.
If your ISDN Card is AVM PCI (Fritz!PCI v2), the RESOURCES should have either
protocol=1 or protocol=2.

I cannot reproduce this problem with redhat-config-network-1.0.0-1 in 7.3 release.

Could you please try to setup your ISDN card again?
Comment 2 Stefan Frings 2002-06-11 13:23:52 EDT
Yes I tested it again. The problem was still there. Then I removed the file
/etc/sysconfig/isdncard and added the card again with the network configuration
utility. It worked fine. It seems that the problem depends on wich ISDN Card I
selected before. I remeber that I accidently selected an PCMCIA Fritz Card and
corrected it later.
In addition I entered again the wrong parameter NONE manually into the file and
opened the network config utility. The I klicked on apply and the file
/etc/sysconfig/isdncard was not changed. Then I selected the protocol EDSS1 and
klicked on apply. Now the parameter in the file was changed to protocol=2.
Comment 3 Stefan Frings 2002-06-11 13:50:47 EDT
I removed the isdn card, set the parameter in the file to NONE and added a new
ISDN Internet connection in the device tab. After a klick on apply the parameter
in the file was still NONE. I tried this many times but I was not able to
reproduce it again. I tried it 5 times but now the parameter is always
"protocol=2".  That looks very strange.
Comment 4 Bill Nottingham 2006-08-04 16:22:27 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.