Bug 663943 - [abrt] exaile-0.3.2.0-2.fc14: tray.py:156:update_menu:UnboundLocalError: local variable 'stock_id' referenced before assignment
Summary: [abrt] exaile-0.3.2.0-2.fc14: tray.py:156:update_menu:UnboundLocalError: loca...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: exaile
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bcc86e82
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-17 13:08 UTC by Raphael Groner
Modified: 2011-03-28 19:33 UTC (History)
1 user (show)

Fixed In Version: exaile-0.3.2.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-04 17:17:58 UTC


Attachments (Terms of Use)
File: backtrace (764 bytes, text/plain)
2010-12-17 13:08 UTC, Raphael Groner
no flags Details

Description Raphael Groner 2010-12-17 13:08:38 UTC
abrt version: 1.1.14
architecture: x86_64
cmdline: python /usr/lib/python2.7/site-packages/exaile/exaile.py --datadir=/usr/share/exaile/data --startgui --start-minimized
component: exaile
executable: /usr/lib/python2.7/site-packages/exaile/exaile.py
kernel: 2.6.35.9-64.fc14.x86_64
package: exaile-0.3.2.0-2.fc14
reason: tray.py:156:update_menu:UnboundLocalError: local variable 'stock_id' referenced before assignment
release: Fedora release 14 (Laughlin)
time: 1292591169
uid: 500

backtrace
-----
tray.py:156:update_menu:UnboundLocalError: local variable 'stock_id' referenced before assignment

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/exaile/xlgui/tray.py", line 255, in on_button_press_event
    self.update_menu()
  File "/usr/lib/python2.7/site-packages/exaile/xlgui/tray.py", line 156, in update_menu
    playpause_image.set_from_stock(stock_id, gtk.ICON_SIZE_MENU)
UnboundLocalError: local variable 'stock_id' referenced before assignment

Local variables in innermost frame:
current_track: 'Love Will Find A New Day (Estigma remix)' from 'Unbekannt' by 'Atlantic Drift feat Vee'
playpause_image: <gtk.Image object at 0x28dd730 (GtkImage at 0x2b732f0)>
self: <TrayIcon object at 0x28da0a0 (GtkStatusIcon at 0x2b20aa0)>

How to reproduce
-----
1. Right click on systray icon
2.
3.

Comment 1 Raphael Groner 2010-12-17 13:08:41 UTC
Created attachment 469357 [details]
File: backtrace

Comment 2 Raphael Groner 2010-12-18 12:24:10 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Right click on systray icon
2.
3.


Comment
-----
crash happened again when right click on the systray icon

Comment 3 Fedora Update System 2011-03-04 15:41:18 UTC
Package exaile-0.3.2.1-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing exaile-0.3.2.1-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/exaile-0.3.2.1-1.fc14
then log in and leave karma (feedback).

Comment 4 Raphael Groner 2011-03-04 17:17:58 UTC
In the meanwhile, I am using Fedora 14 without Exaile. So I am not able to reproduce and closing this bug.

Comment 5 Fedora Update System 2011-03-28 19:31:19 UTC
exaile-0.3.2.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.