Bug 664 - the dev package can be accidentally uninstalled!
the dev package can be accidentally uninstalled!
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-01 13:52 EST by prabhu
Modified: 2014-03-16 22:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-13 14:20:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description prabhu 1999-01-01 13:52:35 EST
The dev package can be accidentally uninstalled and sys
admins who are unaware of this can land up in trouble if
they uninstall this package by mistake.  This may not be a
bug but I have seen cases of people who have actually done
this and had severe problems once they did this.  This is
because according to RPM no package needs dev (this is
obviously very wrong).

# rpm -q --whatrequires dev
no package requires dev
#

prabhu
Comment 1 Alan Cox 2002-12-13 14:06:28 EST
Just scanning over bug pre-history

Its now pinned in place by mkinitrd at least. Surely the kernel can also require
this now ?
Comment 2 Bill Nottingham 2002-12-13 14:20:09 EST
Changed initscripts in CVS to require dev. That should cover most of the
non-esoteric setups.

Note You need to log in before you can comment on or make changes to this bug.