Bug 664012 - kernel can't be rebuild in mock
Summary: kernel can't be rebuild in mock
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Jarod Wilson
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
 
Reported: 2010-12-17 18:20 UTC by Levente Farkas
Modified: 2013-04-01 17:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-20 14:09:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Levente Farkas 2010-12-17 18:20:12 UTC
i try try understand the kernel's spec but it's rather complicated. but if i try to build the noarch subpackages like firmware and doc with:
mock --target "noarch,x86_64" --rebuild kernel-2.6.32-71.7.1.el6.src.rpm
it gives this error:
--------------------------------
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.xDDKKx
+ umask 022
+ cd /builddir/build/BUILD
+ cd kernel-2.6.32-71.7.1.el6
+ LANG=C
+ export LANG
+ unset DISPLAY
+ export 'AFTER_LINK=sh -xc "/usr/lib/rpm/debugedit -b $$RPM_BUILD_DIR -d /usr/src/debug -i $@"'
+ AFTER_LINK='sh -xc "/usr/lib/rpm/debugedit -b $$RPM_BUILD_DIR -d /usr/src/debug -i $@"'
+ rm -rf /builddir/build/BUILDROOT/kernel-2.6.32-71.7.1.el6.noarch
+ mkdir -p /builddir/build/BUILDROOT/kernel-2.6.32-71.7.1.el6.noarch/boot
+ cd linux-2.6.32-71.7.1.el6.noarch
+ make -j1 htmldocs mandocs
  DOCPROC Documentation/DocBook/alsa-driver-api.xml
*** You need to install xmlto ***
make[1]: *** [Documentation/DocBook/alsa-driver-api.html] Error 1
make: *** [htmldocs] Error 2
+ false
error: Bad exit status from /var/tmp/rpm-tmp.xDDKKx (%build)
--------------------------------
but if i build with:
mock --target "x86_64" --rebuild kernel-2.6.32-71.7.1.el6.src.rpm
mock --target "noarch" --rebuild kernel-2.6.32-71.7.1.el6.src.rpm
then it's working.
is it a mock bug or kernel's spec file bug?

Comment 2 Jan Vcelak 2010-12-21 12:53:29 UTC
Changing from RHEL to EPEL.

Comment 3 Levente Farkas 2010-12-21 13:02:55 UTC
why?
imho it's a kernel spec file bug, but i wouldn't like to file it. as in rhel-6's rpm there can be noarch subpackages it should have to fix in kernel's spec and build the noarch subpackages along with the arch packages...

Comment 4 Jan Vcelak 2010-12-23 13:53:04 UTC
Sorry. I haven't read the report very carefully and just switched the product, as mock is not in RHEL but EPEL. This doesn't look like mock bug. Changing to RHEL kernel.

Comment 6 RHEL Program Management 2011-01-07 04:19:55 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 Suzanne Yeghiayan 2011-01-07 16:25:42 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 8 Levente Farkas 2011-01-07 22:40:40 UTC
i don't think it's fixed:-(

Comment 9 Eric Sandeen 2011-01-17 17:42:53 UTC
Is a comma-separated list of targets valid for either mock or for rpmbuild?  I don't see that indicated in either manpage.

-Eric

Comment 10 Levente Farkas 2011-01-17 19:59:54 UTC
both. and it's working for all version of rhel-5, but it's no longer works with rhel-6's kernel since it's spec file changes. anyway as i wrote before the best solution would be to use noarch sub-package in kernel (as all other packages in rhel-6, since this is the new and preferred solution since f12 and rhel-6).

Comment 11 RHEL Program Management 2011-02-01 05:52:00 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 12 RHEL Program Management 2011-02-01 19:00:51 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 13 Levente Farkas 2011-02-06 11:46:03 UTC
it's said that rh not like to fix a regression in it's kernel package...

Comment 14 RHEL Program Management 2011-04-04 02:26:20 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 15 RHEL Program Management 2011-10-07 15:19:01 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 16 Clark Williams 2012-08-08 21:00:20 UTC
I explicitly disallowed the comma-separated target list in the latest version of mock.

Comment 17 Levente Farkas 2013-02-27 12:02:21 UTC
than this bug report is no longer valid...

Comment 18 Jarod Wilson 2013-03-20 14:09:38 UTC
Per comment #16 and comment #17, closing.


Note You need to log in before you can comment on or make changes to this bug.