Bug 664044 - [abrt] system-config-printer-1.2.5-6.fc14: handle_error: Process /usr/bin/python was killed by signal 6 (SIGABRT)
Summary: [abrt] system-config-printer-1.2.5-6.fc14: handle_error: Process /usr/bin/pyt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:98f4282518ca3eece8405cedba9...
: 667111 714950 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-17 19:36 UTC by Brian C. Huffman
Modified: 2011-09-29 01:39 UTC (History)
4 users (show)

Fixed In Version: system-config-printer-1.2.8-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-29 01:39:30 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (41.86 KB, text/plain)
2010-12-17 19:36 UTC, Brian C. Huffman
no flags Details

Description Brian C. Huffman 2010-12-17 19:36:36 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/share/system-config-printer/applet.py
component: system-config-printer
crash_function: handle_error
executable: /usr/bin/python
kernel: 2.6.35.9-64.fc14.x86_64
package: system-config-printer-1.2.5-6.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1292603119
uid: 500

comment
-----
1. Printed a google maps printout from firefox
2. Crash

How to reproduce
-----
1. Printed a google maps printout from firefox
2. Crash
3.

Comment 1 Brian C. Huffman 2010-12-17 19:36:41 UTC
Created attachment 469435 [details]
File: backtrace

Comment 2 Tim Waugh 2010-12-20 14:20:40 UTC
Had you hovered the mouse over the print icon in the notification area?  Had you clicked on that icon at all?

Trying to understand exactly what happened and what sort of tooltip it was trying to display.

Comment 3 Brian C. Huffman 2010-12-20 14:27:17 UTC
I don't think I had the mouse near that icon let alone click on it.  But unfortunately I don't remember exactly.

Comment 4 Jiri Popelka 2011-01-04 14:06:33 UTC
*** Bug 667111 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2011-09-20 11:47:07 UTC
*** Bug 714950 has been marked as a duplicate of this bug. ***

Comment 7 Tim Waugh 2011-09-20 12:44:52 UTC
Seems to happen in JobViewer.set_statusicon_visibility(), here:

        # Let the icon show/hide itself before continuing.
        while self.process_pending_events and gtk.events_pending ():
-->         gtk.main_iteration ()

To trigger this, I think the cursor would need to be hovering over the status icon at the point when it changes from shown to hidden, i.e. when the final print job finishes.  However, when I've tried this I have not been able to reproduce the problem.

One potential way of guarding against this would be to call self.statusicon.set_has_tooltip(False) before that loop.

Comment 8 Fedora Update System 2011-09-20 14:46:20 UTC
system-config-printer-1.2.8-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.8-2.fc14

Comment 9 Fedora Update System 2011-09-21 00:03:29 UTC
Package system-config-printer-1.2.8-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.2.8-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.2.8-2.fc14
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-09-29 01:39:16 UTC
system-config-printer-1.2.8-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.