Bug 664076 - Evolution "Move to Folder..." function doesn't work properly with Gmail IMAP functionality
Summary: Evolution "Move to Folder..." function doesn't work properly with Gmail IMAP ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-17 23:13 UTC by Scott Rushfeldt
Modified: 2010-12-20 08:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-20 08:55:29 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 637642 0 None None None Never

Description Scott Rushfeldt 2010-12-17 23:13:49 UTC
Description of problem:

I have Gmail setup for IMAP access, and have configured Evolution to download my mail from Gmail's IMAP server (imap.googlemail.com).  When in evolution and viewing my Gmail inbox, if I right-click an email message, and select "Move to Folder...", the email appears to be moved to the folder specified.  However, changing to the specified folder briefly shows the email and then it disappears.

Going to the Gmail "trash" folder, shows the moved email is in the trash.

Accessing Gmail through a Firefox browser, and going to the Gmail "trash" folder shows the moved email in the trash with a label  that matches the folder specified in evolution.

Therefore, it appears Evolution is correctly labelling the email and removing the email from the Gmail inbox, when the "Move to Folder..." is performed.  However, Evolution is additionally moving the email to the trash folder, which is incorrect behaviour.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
     Gmail Setup (for IMAP access):
1. Login to Gmail
2. Click "Settings" (Upper right)
3. Click "Forwarding and POP/IMAP"
4. Under "IMAP Access:", select "Enable IMAP"
5. Click "Save Changes"
6. Create a label called "multi/level/testFolder" (labels appear as folders in Evolution.)

     Evolution Setup:
1. Setup Evolution to receive email from "imap.googlemail.com"
2. Enable email receiving option "Automatically synchronize remote mail locally"
3. For folder defaults set:
     a) "Drafts Folder" to "[Gmail]/Drafts"
     b) "Sent Messages Folder" to "[Gmail]/Sent Mail"
     c) "Trash Folder" to "[Gmail]/Trash"
     d) "Junk Folder" to "[Gmail]/Spam"

    Move email:
1. Start evolution, and go to your Gmail account's Inbox (authenticate as needed)
2. Right click on one of the emails, and from the pop-up menu select "Move to Folder..."
3. In the "Move to Folder" window, select the Gmail Account "multi/level/testFolder", and click "Move"
4. View the contents of the folders: "multi/level/testFolder" and "[Gmail]/trash"
5. To see labels on emails in the trash folder:
      a) Start firefox (or another browser)
      b) Login to the Gmail Account
      c) View the contents of the "trash folder" (labels appear before the subject, typically in green.)


Actual results:
The moved email is:
 1. Removed from Gmail's inbox (archived)
 2. Given the "[Gmail]/trash" label (i.e. moved to the "trash" folder)
 3. Given the "multi/level/testFolder" label 
    a) However, due to the email also having a "[Gmail]/trash" label it doesn't appear in evolution's "multi/level/testFolder" folder.  This is probably the correct behavior because if Gmail's trash is emptied, the email will be removed from all folders.

Expected results:
The moved email is only:
 1. Removed from Gmail's inbox (archived)
 2. Given the "multi/level/testFolder" label 

Additional info:

Comment 1 Milan Crha 2010-12-20 08:11:26 UTC
Thanks for a bug report and detailed steps, though from my point of view this is GMail's fault, their incorrect implementation of IMAP protocol. There was an issue with the trash implementation, and they are breaking also move operation. The IMAP protocol doesn't have move operation, it's always copy & delete, which has its own issues, but that's how the protocol is defined. So it seems it'll need yet-another workaround for google mail.

Comment 2 Milan Crha 2010-12-20 08:55:29 UTC
Nonetheless, I agree it should work as expected by users.

I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=637642


Note You need to log in before you can comment on or make changes to this bug.