Bug 664077 - [abrt] fwbackups-1.43.3-1.fc14: cron.py:224:write:CronError: 'Could not write new crontab:\nno crontab for sylvain - using an empty one\n python: can\'t open file \'/usr/bin/cronwriter.py\': [Errno 2] No such file or directory\n crontab: "python /usr/bin/
Summary: [abrt] fwbackups-1.43.3-1.fc14: cron.py:224:write:CronError: 'Could not write...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:87bcc415
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-17 23:22 UTC by Sylvain Arth
Modified: 2010-12-29 21:56 UTC (History)
3 users (show)

Fixed In Version: fwbackups-1.43.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-29 21:51:34 UTC


Attachments (Terms of Use)
File: backtrace (1.60 KB, text/plain)
2010-12-17 23:22 UTC, Sylvain Arth
no flags Details

Description Sylvain Arth 2010-12-17 23:22:54 UTC
abrt version: 1.1.14
architecture: i686
component: fwbackups
executable: /usr/bin/fwbackups-run
kernel: 2.6.35.9-64.fc14.i686.PAE
package: fwbackups-1.43.3-1.fc14
reason: cron.py:224:write:CronError: 'Could not write new crontab:\nno crontab for sylvain - using an empty one\n python: can\'t open file \'/usr/bin/cronwriter.py\': [Errno 2] No such file or directory\n crontab: "python /usr/bin/cronwriter.py" exited with status 2\n'
release: Fedora release 14 (Laughlin)
time: 1292626808
uid: 500

backtrace
-----
cron.py:224:write:CronError: 'Could not write new crontab:\nno crontab for sylvain - using an empty one\n python: can\'t open file \'/usr/bin/cronwriter.py\': [Errno 2] No such file or directory\n crontab: "python /usr/bin/cronwriter.py" exited with status 2\n'

Traceback (most recent call last):
  File "/usr/bin/fwbackups-run", line 97, in <module>
    prefs = config.PrefsConf(create=True)
  File "/usr/lib/python2.7/site-packages/fwbackups/config.py", line 677, in __init__
    self.__import()
  File "/usr/lib/python2.7/site-packages/fwbackups/config.py", line 817, in __import
    cron.write(crontabLines)
  File "/usr/lib/python2.7/site-packages/fwbackups/cron.py", line 224, in write
    raise CronError(_('Could not write new crontab:\n%(a)s%(b)s') % {'a': stdout, 'b': stderr})
CronError: 'Could not write new crontab:\nno crontab for sylvain - using an empty one\n python: can\'t open file \'/usr/bin/cronwriter.py\': [Errno 2] No such file or directory\n crontab: "python /usr/bin/cronwriter.py" exited with status 2\n'

Local variables in innermost frame:
crontabEntry: <fwbackups.cron.rawCrontabLine instance at 0x99344ec>
sub: <subprocess.Popen object at 0x99345ec>
stdout: ''
counter: 0.0
environ: {'VISUAL': u'python /usr/bin/cronwriter.py', 'EDITOR': u'python /usr/bin/cronwriter.py'}
stderr: 'no crontab for sylvain - using an empty one\n python: can\'t open file \'/usr/bin/cronwriter.py\': [Errno 2] No such file or directory\n crontab: "python /usr/bin/cronwriter.py" exited with status 2\n'
fh: <closed file '<fdopen>', mode 'wb' at 0xb76466a8>
crontabEntries: [<fwbackups.cron.rawCrontabLine instance at 0x99344ec>]

comment
-----
Nothing special. I probably installed this software "in cas of" but have never setup it
The this crash is minor but reveals some weakness of it since there is no reason that it crashes for such reason

How to reproduce
-----
1.I dunno
2.
3.

Comment 1 Sylvain Arth 2010-12-17 23:22:58 UTC
Created attachment 469469 [details]
File: backtrace

Comment 2 Stewart Adam 2010-12-18 05:27:56 UTC
Thanks for reporting this.

It looks like you're running fwbackups-run before fwbackups - did you install sets manually? Either way, running just "fwbackups" from the command line to start the GUI interface or starting fwbackups from the Applications menu before running fwbackups-run should resolve this problem.

Comment 3 Raphos 2010-12-19 08:58:50 UTC
Package: fwbackups-1.43.3-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Start a automatic backup
2.
3.

Comment 4 Fedora Update System 2010-12-20 09:18:33 UTC
fwbackups-1.43.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fwbackups-1.43.4-1.fc14

Comment 5 Fedora Update System 2010-12-20 09:18:44 UTC
fwbackups-1.43.4-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fwbackups-1.43.4-1.fc13

Comment 6 Stewart Adam 2010-12-20 09:22:01 UTC
For those affected by this bug, please start the administrator tool after the update. This will re-schedule the backups that have been inadvertently unscheduled as a result of this bug.

This issue was resolved in my internal testing but seeing as this is a relatively severe bug, I'm setting the current status to NEEDINFO just to be sure. If one of the updates listed above solves the problem for you, please remove the NEEDINFO status to confirm. Thanks!

Comment 7 Raphos 2010-12-20 17:44:47 UTC
I had the bug just for the first automatic backup after the update.

Now fwbackups works fine...

Comment 8 Stewart Adam 2010-12-20 18:34:58 UTC
Excellent, thanks for confirming.

If you could please also rate the updates +1, if three people confirm then I will be able to move it to stable early.

Comment 9 Fedora Update System 2010-12-20 22:05:06 UTC
fwbackups-1.43.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fwbackups'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fwbackups-1.43.4-1.fc14

Comment 10 Raphos 2010-12-21 20:21:57 UTC
Hi,

I've downloaded fwbackups.noarch 1.43.4-1.fc14 from updates-testing.

Ran manually "backup set now".

No bug.

Comment 11 Jeremy Bennett 2010-12-22 09:25:18 UTC
Package: fwbackups-1.43.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.From a crontab job while I was out of the office.
2.
3.


Comment
-----
This is a regular crontab sponsored execution. I do note that we have recently had a number of power failures locally, so this may have left software in an inconsistent state.

Comment 12 Stewart Adam 2010-12-22 15:52:03 UTC
(Jeremy, please try updating to the testing release and running the backup administrator tool to fix the crashes - merely starting and then closing it will work around the bug)

Comment 13 Jeremy Bennett 2010-12-22 16:12:43 UTC
Thanks for the quick response - I'll do that.


Jeremy

Comment 14 Fedora Update System 2010-12-29 21:51:24 UTC
fwbackups-1.43.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-12-29 21:56:05 UTC
fwbackups-1.43.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.