Bug 664134 - SELinux is preventing /var/lib/boinc/projects/setiathome.berkeley.edu/setiathome-5.28.x86_64-pc-linux-gnu "connectto" access on /tmp/.X11-unix/X0.
Summary: SELinux is preventing /var/lib/boinc/projects/setiathome.berkeley.edu/setiath...
Keywords:
Status: CLOSED DUPLICATE of bug 664133
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:6a323e3e842...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-18 14:38 UTC by avc4ge28
Modified: 2010-12-20 10:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-20 10:14:14 UTC


Attachments (Terms of Use)

Description avc4ge28 2010-12-18 14:38:56 UTC
Summary:

SELinux is preventing
/var/lib/boinc/projects/setiathome.berkeley.edu/setiathome-5.28.x86_64-pc-linux-gnu
"connectto" access on /tmp/.X11-unix/X0.

Detailed Description:

[setiathome-5.28 has a permissive type (boinc_project_t). This access was not
denied.]

SELinux denied access requested by setiathome-5.28. It is not expected that this
access is required by setiathome-5.28 and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:boinc_project_t:s0
Target Context                system_u:system_r:xserver_t:s0-s0:c0.c1023
Target Objects                /tmp/.X11-unix/X0 [ unix_stream_socket ]
Source                        setiathome-5.28
Source Path                   /var/lib/boinc/projects/setiathome.berkeley.edu/se
                              tiathome-5.28.x86_64-pc-linux-gnu
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.7-16.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.9-64.fc14.x86_64 #1 SMP
                              Fri Dec 3 12:19:41 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 18 Dec 2010 08:34:42 AM CST
Last Seen                     Sat 18 Dec 2010 08:34:42 AM CST
Local ID                      af2750bd-c17f-4284-b9fe-5e3113c52050
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1292682882.770:31): avc:  denied  { connectto } for  pid=2762 comm="setiathome-5.28" path="/tmp/.X11-unix/X0" scontext=system_u:system_r:boinc_project_t:s0 tcontext=system_u:system_r:xserver_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=(removed) type=SYSCALL msg=audit(1292682882.770:31): arch=c000003e syscall=42 success=yes exit=0 a0=8 a1=7fff6866a640 a2=13 a3=1 items=0 ppid=1438 pid=2762 auid=4294967295 uid=492 gid=487 euid=492 suid=492 fsuid=492 egid=487 sgid=487 fsgid=487 tty=(none) ses=4294967295 comm="setiathome-5.28" exe="/var/lib/boinc/projects/setiathome.berkeley.edu/setiathome-5.28.x86_64-pc-linux-gnu" subj=system_u:system_r:boinc_project_t:s0 key=(null)



Hash String generated from  catchall,setiathome-5.28,boinc_project_t,xserver_t,unix_stream_socket,connectto
audit2allow suggests:

#============= boinc_project_t ==============
allow boinc_project_t xserver_t:unix_stream_socket connectto;

Comment 1 avc4ge28 2010-12-19 11:54:44 UTC
This bug occurs after system reboot and login.

Comment 2 Miroslav Grepl 2010-12-20 10:14:14 UTC

*** This bug has been marked as a duplicate of bug 664133 ***


Note You need to log in before you can comment on or make changes to this bug.