Bug 664191 - Kernel 2.6.35.10-67 (and -68) hang on boot with IR related error
Summary: Kernel 2.6.35.10-67 (and -68) hang on boot with IR related error
Keywords:
Status: CLOSED DUPLICATE of bug 664145
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-19 01:08 UTC by Dario Castellarin
Modified: 2010-12-23 20:35 UTC (History)
9 users (show)

Fixed In Version: kernel-2.6.35.10-72.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-23 20:35:54 UTC


Attachments (Terms of Use)
dmesg of kernel 2.6.35.9-65, which boots fine (67.10 KB, text/plain)
2010-12-19 01:08 UTC, Dario Castellarin
no flags Details

Description Dario Castellarin 2010-12-19 01:08:56 UTC
Created attachment 469560 [details]
dmesg of kernel 2.6.35.9-65, which boots fine

Description of problem:
Since kernel 2.6.35.10-67, my laptop (Compal JFL92) hangs on boot. I'm not able to login or ssh to it, so I cannot provide much information, however it seems related to the loading of the driver for the IR device, which uses the ene_ir driver. Blacklisting the driver doesn't help. It might also be an error on how udev handles the process. The error I see in text console is this:

udevd-work[517] '/sbin/modprobe -bv acpi:ENE0100:' unexpected exit with status 0x0009

I cannot obtain a kernel log of the boot process, however I attach that of kernel 2.6.35.9-65, which is the last version that works fine on my system. I'm available for further information if required!

Version-Release number of selected component (if applicable):
kernel-2.6.35.10-67.fc14.x86_64

How reproducible:
Always on boot

Steps to Reproduce:
1. Just boot with kernel-2.6.35.10-67.fc14.x86_64
  
Actual results:
System hangs with error from udevd-work

Expected results:
System boots fine

Comment 1 Fedora Update System 2010-12-19 23:56:39 UTC
kernel-2.6.35.10-69.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.10-69.fc14

Comment 2 Jarod Wilson 2010-12-20 02:04:51 UTC
Hrm, don't have any ene hardware myself, will have to point the driver author towards this bug, see if he has any ideas... I presume if you move ene_ir.ko out of the kernel module path entirely, the system boots fine?

Comment 3 antonio montagnani 2010-12-20 11:49:56 UTC
see bug 664145, for x86 systems

Comment 4 Dario Castellarin 2010-12-20 13:13:42 UTC
Sorry I'm having some plane misadventures right now, however I should be able to try that this evening (Central Europe time).

Comment 5 Jarod Wilson 2010-12-20 15:23:04 UTC

*** This bug has been marked as a duplicate of bug 664145 ***

Comment 6 Fedora Update System 2010-12-21 13:55:14 UTC
kernel-2.6.35.10-72.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.10-72.fc14

Comment 7 Fedora Update System 2010-12-22 19:51:51 UTC
kernel-2.6.35.10-72.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 antonio montagnani 2010-12-22 20:02:58 UTC
Problem still persists with kernel-2.6.35.10-72.fc14

Comment 9 Kyle McMartin 2010-12-22 21:33:01 UTC
Yeah, I'll try to sort out a workaround unless Jarod beats me to it. (Probably just restore the 'classic' driver which worked.)

Comment 10 Bill Gianopoulos 2010-12-23 18:09:14 UTC
This would seem to be a duplicate of bug 664145.

Comment 11 Jarod Wilson 2010-12-23 20:35:54 UTC

*** This bug has been marked as a duplicate of bug 664145 ***


Note You need to log in before you can comment on or make changes to this bug.