Bug 664193 - [abrt] freeciv-2.2.2-2.fc14: total_activity_targeted: Process /usr/bin/freeciv-server was killed by signal 6 (SIGABRT)
Summary: [abrt] freeciv-2.2.2-2.fc14: total_activity_targeted: Process /usr/bin/freeci...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeciv
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Thomas Janssen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7fffe1199910959ccc97ab1ac2b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-19 01:15 UTC by Héctor Vucetich
Modified: 2011-01-12 05:28 UTC (History)
3 users (show)

Fixed In Version: freeciv-2.2.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-12 05:28:02 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (3.25 KB, text/plain)
2010-12-19 01:15 UTC, Héctor Vucetich
no flags Details

Description Héctor Vucetich 2010-12-19 01:15:23 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: freeciv-server -p 5556 -q 1 -e --saves ~/.freeciv/saves --scenarios ~/.freeciv/scenarios
component: freeciv
crash_function: total_activity_targeted
executable: /usr/bin/freeciv-server
kernel: 2.6.35.9-64.fc14.i686.PAE
package: freeciv-2.2.2-2.fc14
rating: 4
reason: Process /usr/bin/freeciv-server was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1292721233
uid: 500

How to reproduce
-----
1. Start freeciv
2. Play
3. The crash occurs

Comment 1 Héctor Vucetich 2010-12-19 01:15:26 UTC
Created attachment 469561 [details]
File: backtrace

Comment 2 Héctor Vucetich 2010-12-19 16:24:57 UTC
Package: freeciv-2.2.2-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start freeciv
2. Play
3. The crash occurs


Comment
-----
The crash seems to occur when a round is finished. Besides, it happens at random.

Comment 3 Héctor Vucetich 2010-12-25 21:28:30 UTC
Package: freeciv-2.2.2-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. The crash occurs at the end of a turn, after many turns of normal behavior
2.
3.


Comment
-----
The crash is sporadic

Comment 4 Henning Norén 2010-12-29 23:31:34 UTC
Package: freeciv-2.2.2-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Play with AI and let one of the AI units pillage one of your cities.


Comment
-----
Seems to be related to the tickets fixed in Freeciv 2.2.3:
http://gna.org/bugs/?16100
http://gna.org/bugs/?16418

Upgrading to 2.2.4 should resolve this problem.

Comment 5 Fedora Update System 2010-12-30 17:30:29 UTC
freeciv-2.2.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/freeciv-2.2.4-1.fc14

Comment 6 Fedora Update System 2010-12-31 20:56:37 UTC
freeciv-2.2.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freeciv'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/freeciv-2.2.4-1.fc14

Comment 7 Michael Epley 2011-01-09 04:40:00 UTC
Package: freeciv-2.2.2-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. playing freeciv game -- single player, doing nothing particularly unusual

Comment 8 Fedora Update System 2011-01-12 05:27:48 UTC
freeciv-2.2.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.