Bug 664206 - kernel-2.6.35.10-68.fc14 - "*ERROR* Invalid command stream !" with Radeon HD 4770
Summary: kernel-2.6.35.10-68.fc14 - "*ERROR* Invalid command stream !" with Radeon HD ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-19 08:30 UTC by Jaroslav Pulchart
Modified: 2010-12-22 19:52 UTC (History)
9 users (show)

Fixed In Version: kernel-2.6.35.10-72.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-22 19:52:37 UTC


Attachments (Terms of Use)
gdm.jpg (311.25 KB, image/jpeg)
2010-12-19 08:31 UTC, Jaroslav Pulchart
no flags Details
gnome-panel.jpg (223.07 KB, image/jpeg)
2010-12-19 08:31 UTC, Jaroslav Pulchart
no flags Details
gnome-session.jpg (270.23 KB, image/jpeg)
2010-12-19 08:32 UTC, Jaroslav Pulchart
no flags Details
dmesg.out (123.39 KB, text/plain)
2010-12-19 08:33 UTC, Jaroslav Pulchart
no flags Details
lspci.out (10.08 KB, text/plain)
2010-12-19 08:33 UTC, Jaroslav Pulchart
no flags Details
Xorg.0.log (128.67 KB, text/plain)
2010-12-19 08:34 UTC, Jaroslav Pulchart
no flags Details

Description Jaroslav Pulchart 2010-12-19 08:30:32 UTC
Description of problem:
I upgraded the kernel and kernel-devel packages from testing repository (	kernel-2.6.35.10-68.fc14). I see only "broken" screen of X after I rebooted to this new kernel and the system log is full of "[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !" (see dmesg.out).

Version-Release number of selected component (if applicable):
kernel-2.6.35.10-68.fc14

How reproducible:
boot to runlevel 5

Steps to Reproduce:
1. each boot to runlevel 5
2.
3.
  
Actual results:
see attached gdm.jpg, gnome-session.jpg and gnome-panel.jpg photos

Expected results:


Additional info:
see attached dmesg.out, lspci.out and Xorg.0.log files

Comment 1 Jaroslav Pulchart 2010-12-19 08:31:16 UTC
Created attachment 469569 [details]
gdm.jpg

Comment 2 Jaroslav Pulchart 2010-12-19 08:31:54 UTC
Created attachment 469570 [details]
gnome-panel.jpg

Comment 3 Jaroslav Pulchart 2010-12-19 08:32:19 UTC
Created attachment 469571 [details]
gnome-session.jpg

Comment 4 Jaroslav Pulchart 2010-12-19 08:33:33 UTC
Created attachment 469572 [details]
dmesg.out

Comment 5 Jaroslav Pulchart 2010-12-19 08:33:55 UTC
Created attachment 469573 [details]
lspci.out

Comment 6 Jaroslav Pulchart 2010-12-19 08:34:24 UTC
Created attachment 469574 [details]
Xorg.0.log

Comment 7 Jaroslav Pulchart 2010-12-20 08:44:10 UTC
valid for kernel-2.6.35.10-69 too

Comment 8 Jaroslav Pulchart 2010-12-20 09:44:52 UTC
I will try revert this commit "881fe6c1d06bf49f4ab7aef212cdaf66bd059614" later this day. I expect that it will help for my HW.

http://git.kernel.org/?p=linux/kernel/git/longterm/linux-2.6.35.y.git;a=commitdiff;h=b8e9a4a45f8427837f4dba89bda4d4e3f3a5c726;hp=cde76274952b114223f4b36123ffa3450c5bbf8a

Comment 9 John Thacker 2010-12-20 13:34:58 UTC
I see the same problem with a Radeon HD 4870.

Comment 10 Kyle McMartin 2010-12-20 13:45:49 UTC
Dave, is stable 2.6.35 missing something? Should we back out that patch for now?

--Kyle

Comment 11 Kyle McMartin 2010-12-20 14:02:09 UTC
commit f30df2fad0c901e74ac9a52a488a54c69a373a41
Author: Dave Airlie <airlied@redhat.com>
Date:   Thu Oct 21 13:55:40 2010 +1000

    drm/radeon/r600: fix tiling issues in CS checker.
    
    The CS checker had some incorrect alignment requirements for 2D surfaces,
    this made rendering to mipmap levels that were 2D broken.
    
    Also the CB height was being worked out from the BO size, this doesn't work
    at all when rendering mipmap levels, instead we work out what height userspace
    wanted from slice max and use that to check it fits inside the BO, however
    the DDX send the wrong slice max for an unaligned buffer so we have to workaround
    for that even though its a userspace bug.
    
    Reviewed-by: Alex Deucher <alexdeucher@gmail.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>

looks like it might help?

Comment 12 John Thacker 2010-12-20 14:43:01 UTC
That might help, but note that there was a subsequent commit fixing typos in that commit:

commit	d33ef52d9db8a36900dd53f2e32db9a521ace259

drm/radeon/kms: fix typo in r600 cs checker

Looks like a typo in:
drm/radeon/r600: fix tiling issues in CS checker.
(f30df2fad0c901e74ac9a52a488a54c69a373a41)

Signed-off-by: Alex Deucher <alexdeucher@gmail.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>

Comment 13 Kyle McMartin 2010-12-20 14:55:28 UTC
And a subsequent revert of that...

Comment 14 John Thacker 2010-12-20 14:59:47 UTC
Ah yes, good point.

Comment 15 Kyle McMartin 2010-12-20 15:25:53 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2677662

Could you try this scratch build when it completes?

Comment 16 Jaroslav Pulchart 2010-12-20 17:25:14 UTC
Kernel build from comment 15 is OK :)

Comment 17 Kyle McMartin 2010-12-20 17:34:53 UTC
Great, thanks. I'll talk to airlied and try to get something fixed in the next build.

Comment 18 John Thacker 2010-12-20 20:36:39 UTC
I'll chime in and say that that the kernel-2.6.35.10-69.bz664206.fc14 build WORKSFORME as well.

Comment 19 Michal Hlavinka 2010-12-21 06:10:06 UTC
I can see this error:
Dec 21 06:59:47 nbone kernel: [  313.658517] radeon 0000:01:00.0: r600_cs_track_validate_cb:203 cb pitch (64) invalid
Dec 21 06:59:47 nbone kernel: [  313.658530] radeon 0000:01:00.0: r600_packet3_check:1108 invalid cmd stream 423
Dec 21 06:59:47 nbone kernel: [  313.658537] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

in both
kernel-2.6.35.10-68.fc14.x86_64
kernel-2.6.35.10-69.fc14.x86_64

Comment 20 Michal Hlavinka 2010-12-21 09:17:36 UTC
kernel-2.6.35.10-72.fc14.x86_64 works fine

Comment 21 Jaroslav Pulchart 2010-12-21 10:07:11 UTC
Yes, kernel kernel-2.6.35.10-72.fc14.x86_64 include new patch drm-radeon-r600-cs-checker-fixes.patch which fixed this issue.

Comment 22 Fedora Update System 2010-12-21 13:54:55 UTC
kernel-2.6.35.10-72.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.10-72.fc14

Comment 23 Fedora Update System 2010-12-22 00:03:15 UTC
kernel-2.6.35.10-72.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kernel-2.6.35.10-72.fc14

Comment 24 Fedora Update System 2010-12-22 19:51:31 UTC
kernel-2.6.35.10-72.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.