Bug 66426 - vgetty fails on USR Sportster
vgetty fails on USR Sportster
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-10 08:15 EDT by Jan "Yenya" Kasprzak
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-01 18:35:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2002-06-10 08:15:42 EDT
Description of Problem:
The vgetty does not work with US Robotics Sportster modems. It answers the
incoming call, but then it immediately hangs up the line. After thet it
continues the normal operation (starting the call_program or playing the welcome
message). The line is already hung up at that time, however.

Version-Release number of selected component (if applicable):
1.1.28 (maybe earlier as well).

How Reproducible:
100% (tried 10 USR modems some of it with different firmware). It worked on
RedHat 5.2 systems (dont know the version of mgetty-voice package in RH5.2).

Steps to Reproduce:
1. configure vgetty on a serial line
2. connect the USR sportster to the line
3. call the phone number

Actual Results:
It picks up the call, but immediately hangs up.

Expected Results:
Playing the welcome message, then recording the data.

Additional Information:
I've discovered (by re-typing the AT commands from vgetty log file by hand) that
it hangs up the line after the AT#VLS=0 command. I've found this command in the
mgetty-1.1.28/voice/libvoice/US_Robotics.c file near the line 292. After
changing this to "AT#VLS=0A" it started to work. Patch is as follows:

--- mgetty-1.1.28/voice/libvoice/US_Robotics.c.orig	Mon Jun 10 13:41:05 2002+++ mgetty-1.1.28/voice/libvoice/US_Robotics.c	Mon Jun 10 13:34:10 2002
@@ -289,7 +289,7 @@
                voice_command("AT#VLS=0H0","OK|VCON");
                return(OK);
           case DIALUP_LINE:
-               voice_command("AT#VLS=0","OK|VCON");
+               voice_command("AT#VLS=0A","OK|VCON");
                return(OK);
 	  case LOCAL_HANDSET:  /* by gmilner@my-dejanews.com */
 	      voice_command("AT#VLS=1","OK|VCON");

-Jan "Yenya" Kasprzak
Comment 1 Jason Vas Dias 2005-08-01 18:35:12 EDT
Apologies for the long delay in processing this bug - it got lost somehow.
As I have no USR Sportster modem which which to test, I cannot verify this
patch. I have sent the patch upstream and will incorporate it when it appears
in the next upstream release.

Note You need to log in before you can comment on or make changes to this bug.