Bug 66431 - Segfault in gtk.glade.XML
Segfault in gtk.glade.XML
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pygtk2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-06-10 11:05 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 23:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-06-10 11:05:41 EDT
Description of Problem: 
Python programs using gtk.glade.XML crash on .glade files that should work. 
 
Version-Release number of selected component (if applicable): 
python-2.2.1-7 
glade2-1.1.0-3 
libglade2-1.99.12-4 
pygtk2-1.99.10-3 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
1. Start glade-2 
2. Project->New 
3. "New Gnome Project" 
4. From Palette, select 'Gnome' features 
5. Click on the 'Gnome Application Window' button 
6. Save with default file name. 
7. cd ~/Projects/project1 
8. python 
>>> import gtk.glade 
>>> gtk.glade.XML("project1.glade") 
 
Actual Results: 
 
(:14672): GLib-GObject-WARNING **: invalid cast from (NULL) pointer to 
`GObject' 
 
(:14672): GLib-GObject-CRITICAL **: file gobject.c: line 975 (g_object_get): 
assertion `G_IS_OBJECT (object)' failed 
Segmentation fault 
 
Expected Results: 
No segfault, just another prompt. 
 
Additional Information: 
This is holding up the printconf pygtk2 port.
Comment 1 Tim Waugh 2002-06-17 10:03:03 EDT
This seems to be fixed now, at a cursory test.

Note You need to log in before you can comment on or make changes to this bug.