Bug 664334 - libical has race in populating builtin timezones
Summary: libical has race in populating builtin timezones
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libical
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-19 23:02 UTC by Robert Scheck
Modified: 2017-12-06 10:24 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 10:24:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Scheck 2010-12-19 23:02:04 UTC
Description of problem:
The libical package has race in populating builtin timezones, see bug #637150
for further details.

Version-Release number of selected component (if applicable):
libical-0.43-5.1.el6

How reproducible:
Depends on the time of simultaneously calls.

Actual results:
libical has race in populating builtin timezones.

Expected results:
No races anymore because of libical-0.46-icaltimezone.patch.

Additional info:
http://pkgs.fedoraproject.org/gitweb/?p=libical.git;a=blob;f=libical-0.46-icaltimezone.patch;hb=HEAD
is the patch this report is talking about.

Comment 2 RHEL Program Management 2011-01-07 15:48:51 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Jan Kurik 2017-12-06 10:24:09 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.