Bug 664352 - Uneven mouse behavior when using Microsoft Media Desktop 1000 set wireless mouse
Summary: Uneven mouse behavior when using Microsoft Media Desktop 1000 set wireless mouse
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 03:14 UTC by Gilboa Davara
Modified: 2018-04-11 18:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-26 06:09:57 UTC
Type: ---


Attachments (Terms of Use)
Xorg.conf (1.56 KB, application/octet-stream)
2010-12-20 03:14 UTC, Gilboa Davara
no flags Details
Xorg.0.log (17.35 KB, application/octet-stream)
2010-12-20 03:20 UTC, Gilboa Davara
no flags Details
Xorg.conf (right mime type) (1.56 KB, text/plain)
2010-12-20 03:22 UTC, Gilboa Davara
no flags Details
Xorg.0.log (right mime type) (17.35 KB, text/plain)
2010-12-20 03:23 UTC, Gilboa Davara
no flags Details
evtest-capture outpuit (8.50 KB, application/x-bzip2)
2010-12-22 16:19 UTC, Gilboa Davara
no flags Details
uncompressed evtest-capture.xml (169.71 KB, text/plain)
2010-12-22 17:27 UTC, Matěj Cepl
no flags Details
Slow and fast scroll. (3.46 KB, application/x-gzip)
2011-01-09 14:50 UTC, Gilboa Davara
no flags Details

Description Gilboa Davara 2010-12-20 03:14:39 UTC
Created attachment 469662 [details]
Xorg.conf

As the title suggests, I'm deploying Fedora on machines with Microsoft Media Desktop 1000 keyboard / mouse wireless combo.
On all machines I get uneven mouse acceleration and especially broken mouse-wheel behavior (E.g. uneven scroll speed, sometimes slow, sometimes fast, sometimes backwards, etc).
Needless to say, according to the users, Windows 7 (ugh) doesn't produce the same results.
I should point out that Xorg was very good at detecting the keyboard, including the media buttons.

Xorg.conf and Xorg.log attached.
P.S. machines are using the proprietary nVidia driver. I can test w/o it, if it matters.

- Gilboa

Comment 1 Gilboa Davara 2010-12-20 03:20:37 UTC
Created attachment 469664 [details]
Xorg.0.log

Comment 2 Gilboa Davara 2010-12-20 03:22:14 UTC
Created attachment 469665 [details]
Xorg.conf (right mime type)

Comment 3 Gilboa Davara 2010-12-20 03:23:21 UTC
Created attachment 469667 [details]
Xorg.0.log (right mime type)

Comment 4 Gilboa Davara 2010-12-20 03:24:36 UTC
$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Microsft Microsoft Wireless Desktop Receiver 3.1  id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Microsft Microsoft Wireless Desktop Receiver 3.1  id=8    [slave  keyboard (3)]

Comment 5 Matěj Cepl 2010-12-20 23:54:18 UTC
Looking at https://fedoraproject.org/wiki/Xorg/Input_Triage_Algorithm and discussing this with our developers, I believe that the most important information which we could use is the file generated by the evtest-capture command (from the package evtest) against the devices. Please, generate it and attach to this issue report.

Thank you

Comment 6 Gilboa Davara 2010-12-22 16:19:06 UTC
Created attachment 470249 [details]
evtest-capture outpuit

I tried to record broken behavior (E.g. even reversed mouse-wheel, weird uneven acceleration, etc).

If you want me to record certain evens (to clean up the log) please let me know.

- Gilboa

Comment 7 Gilboa Davara 2010-12-22 16:24:54 UTC
In the case of the mouse-wheel, I should point out that if I -slowly- turn it, I get more-or-less working scroll. If I increase the wheel speed, I get no scroll, or even reverse scroll.

- Gilboa

Comment 8 Matěj Cepl 2010-12-22 17:27:24 UTC
Created attachment 470269 [details]
uncompressed evtest-capture.xml

Comment 9 Peter Hutterer 2011-01-04 01:13:15 UTC
(In reply to comment #6)
> If you want me to record certain evens (to clean up the log) please let me
> know.

yes please, it's hard to know what I'm looking for. right now I see the mouse move and scroll my window, but I don't know what exactly I'm looking for.

as for different behaviour: in situations where scrolling causes an application to render large parts, it may seem slower. e.g. scrolling in firefox will feel slower than scrolling in a terminal. this isn't something we can fix in the driver though.

as for the reverse scroll: do you see the reverse scroll in evtest and/or in xev?

Comment 10 Gilboa Davara 2011-01-09 14:50:37 UTC
Created attachment 472443 [details]
Slow and fast scroll.

OK.
I tried to record specific events.
I've opened up firefox in a test-only site that includes ~3 pages worth of text.
I recorded the mouse events twice, once while slowly turning the mouse-wheel (evtest-capture-slow.xml) from the top of the page to the bottom and than back, and once while turning the mouse-wheel at a what I consider normal rate (evtest-capture-fast.xml), again top to bottom and than back.

In both cases, scrolling was pretty slow and uneven, as if large number of events simply disappeared.
During the fast scroll test, I noticed at least once reverse scroll event.

I should add that I'm conducting this test on a dual Xeon machine with nVidia 9400 GPU w/ latest proprietary drivers. I doubt that this problem is rending related. (Scrolling using PageUp/Dn seems clean of any type of artifacts).

- Gilboa

Comment 11 Gilboa Davara 2011-01-09 14:51:38 UTC
P.S. Can I somehow record pure USB HID events?

Comment 12 Peter Hutterer 2012-06-26 06:09:57 UTC
This bug was filed against Fedora 14 which is now EOL. Please re-open this bug if you still experience this issue with one of the currently suppported versions of Fedora. Don't forget to update the version field if you do so.


Note You need to log in before you can comment on or make changes to this bug.