Bug 664357 - guest kernel panic when boot with sse4.2 on host not support sse4.2
guest kernel panic when boot with sse4.2 on host not support sse4.2
Status: CLOSED DUPLICATE of bug 664363
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: john cooper
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-12-19 23:46 EST by Suqin Huang
Modified: 2014-07-24 23:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 15:20:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel panic (22.36 KB, image/png)
2010-12-19 23:58 EST, Suqin Huang
no flags Details

  None (edit)
Description Suqin Huang 2010-12-19 23:46:04 EST
Description of problem:
"kernel panic - not syncing: Attempted to kill init!" when boot rhel6-i386 with sse4.2 on host not support sse4.2

Version-Release number of selected component (if applicable):
kvm-83-223.el5

How reproducible:
100% 

Steps to Reproduce:
1. cmd
/usr/libexec/qemu-kvm -drive file=/images/RHEL-Server-6.0-32.qcow2,index=0,if=ide,media=disk,cache=none,format=qcow2 -net nic,vlan=0,model=rtl8139,macaddr=00:1a:20:68:80:e6 -net tap,vlan=0,script=/kvm/scripts/qemu-ifup-switch,downscript=no -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2,+sse4.2 -vnc :1 -rtc-td-hack -M rhel5.6.0 -usbdevice tablet -no-kvm-pit-reinjection -boot c -monitor stdio
2.
3.
  
Actual results:
"kernel panic - not syncing: Attempted to kill init!"

Expected results:


Additional info:
1. host
kernel: 2.6.18-237.el5

cpu:
processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz
stepping	: 10
cpu MHz		: 2000.000
cache size	: 3072 KB

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr sse4_1 lahf_lm

[root@intel-q9400-4-2 kvm]# cat /proc/cmdline 
ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 console=tty0

2. can not reproduce when boot without sse4.2
3. can not reproduce on i7 host (support sse4.2)

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm

3. guest
2.6.32-71.el6.i686
Comment 1 Suqin Huang 2010-12-19 23:58:07 EST
Created attachment 469674 [details]
kernel panic

reproduce when install guest with sse4.2
Comment 2 john cooper 2011-01-13 15:20:12 EST
Looks like we have a cpu flag verification problem relative to host
flags.  Appears to be a dup of 664363, moving to that case.

*** This bug has been marked as a duplicate of bug 664363 ***

Note You need to log in before you can comment on or make changes to this bug.