Bug 664400 - abrt refuses to work
Summary: abrt refuses to work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 10:18 UTC by Ralf Corsepius
Modified: 2015-02-01 22:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-20 11:50:38 UTC
Type: ---


Attachments (Terms of Use)
sc (67.03 KB, image/png)
2010-12-20 11:47 UTC, Ralf Corsepius
no flags Details

Description Ralf Corsepius 2010-12-20 10:18:45 UTC
Description of problem:
Abrt refuses to work.

Version-Release number of selected component (if applicable):
# rpm -qa 'abrt*'
abrt-addon-ccpp-1.1.14-1.fc14.x86_64
abrt-1.1.14-1.fc14.x86_64
abrt-plugin-runapp-1.1.14-1.fc14.x86_64
abrt-libs-1.1.14-1.fc14.x86_64
abrt-addon-kerneloops-1.1.14-1.fc14.x86_64
abrt-plugin-logger-1.1.14-1.fc14.x86_64
abrt-plugin-bugzilla-1.1.14-1.fc14.x86_64
abrt-addon-python-1.1.14-1.fc14.x86_64
abrt-cli-1.1.14-1.fc14.x86_64
abrt-gui-1.1.14-1.fc14.x86_64


How reproducible:
No idea.

Steps to Reproduce:
1. install perl-padre
2. try to run it
/usr/bin/padre
=> Segfault, abrt "flash goes on", try to submit abrt report to bugzilla.
3. Abrt tells to run "debuginfo-install perl-Padre"
=> Become root and run "debuginfo-install perl-Padre"
4. debuginfo-install fails
# debuginfo-install perl-Padre
...
Could not find debuginfo for main pkg: perl-Padre-0.64-1.fc14.noarch
No debuginfo packages available to install
5. Abrt refuses to accept report.
  
Actual results:
Abrt refuses to work.


Expected results:
Abrt to accept report.

Additional info:
This case nicely exhibits several of the design flaws ABRT suffers from:
- Reporting requires "root"
- debuginfo retrieval is dysfunctional.
- ABRT does not offer escape to report issues if its wanna-be automatisms fail.

Comment 1 Jiri Moskovcak 2010-12-20 11:00:16 UTC
> 
> Additional info:
> This case nicely exhibits several of the design flaws ABRT suffers from:
> - Reporting requires "root"

- no, it doesn't need root! I told you few times and it seems you either suffer from serious memory loss or just want to be a troll, so one last time: only the debuginfo-install script requires root and it's not part of ABRT it's part of yum-utils and ABRT suggest to use it only if it's own debuginfo mechanism fails

> - debuginfo retrieval is dysfunctional.

- agree, but this is not ABRT fault, so please report this to fedora infrastructure or to yum-utils

> - ABRT does not offer escape to report issues if its wanna-be automatisms fail.
- by escape you mean a button "Ignore this crash"? if so, then you can be happy as it's already on our TODO list...

Comment 2 Ralf Corsepius 2010-12-20 11:24:57 UTC
(In reply to comment #1)
> > 
> > Additional info:
> > This case nicely exhibits several of the design flaws ABRT suffers from:
> > - Reporting requires "root"
> 
> - no, it doesn't need root! I told you few times and it seems you either suffer
> from serious memory loss or just want to be a troll, so one last time: only the
> debuginfo-install script requires root and it's not part of ABRT it's part of
> yum-utils and ABRT suggest to use it only if it's own debuginfo mechanism fails
Stop twisting words - You are cheating to yourself and to your users!

Abrt instructs users to run "debuginfo-install"

Running debuginfo-install requires root => user _must_ become "root".

=> Your statement "no. it doesn't need root!" is a lie.

QED.

Comment 3 Ralf Corsepius 2010-12-20 11:47:26 UTC
Created attachment 469732 [details]
sc

Screenshot demonstrating that ABRT requires root.

Upper part of the image:
 ABRT report form instructing user to run "debuginfo-install" and refusing to send the report because of lack of debuginfos.

Lower part of the image:
 Terminal in which the user tried to run "debuginfo-install"

Consequences: User can not avoid to become "root" or, if he doesn't have the privilege to have root access, to call his sys-admin.

Comment 4 Jiri Moskovcak 2010-12-20 11:50:38 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > > 
> > > Additional info:
> > > This case nicely exhibits several of the design flaws ABRT suffers from:
> > > - Reporting requires "root"
> > 
> > - no, it doesn't need root! I told you few times and it seems you either suffer
> > from serious memory loss or just want to be a troll, so one last time: only the
> > debuginfo-install script requires root and it's not part of ABRT it's part of
> > yum-utils and ABRT suggest to use it only if it's own debuginfo mechanism fails
> Stop twisting words - You are cheating to yourself and to your users!
> 

- what's not true on the statement above? I can easily show you the part of the code in 
ABRT which tries to download the debuginfo and does NOT need root...

> Abrt instructs users to run "debuginfo-install"
> 

- it doesn't instruct it politely asks:
Please try to install debuginfo manually using the command: <b>debuginfo-install %s</b>

> Running debuginfo-install requires root => user _must_ become "root".
> 
> => Your statement "no. it doesn't need root!" is a lie.
> 
> QED.

- and as usual you deliberately ignored the rest of the message... troll indeed...

Comment 5 Ralf Corsepius 2010-12-20 12:25:33 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > > 
> > > > Additional info:
> > > > This case nicely exhibits several of the design flaws ABRT suffers from:
> > > > - Reporting requires "root"
> > > 
> > > - no, it doesn't need root! I told you few times and it seems you either suffer
> > > from serious memory loss or just want to be a troll, so one last time: only the
> > > debuginfo-install script requires root and it's not part of ABRT it's part of
> > > yum-utils and ABRT suggest to use it only if it's own debuginfo mechanism fails
> > Stop twisting words - You are cheating to yourself and to your users!
> > 
> 
> - what's not true on the statement above? I can easily show you the part of the
> code in 
> ABRT which tries to download the debuginfo and does NOT need root...

Well, then explain why it doesn't work - The screenshot is unmisunderstandably clear.

> > Abrt instructs users to run "debuginfo-install"
> > 
> 
> - it doesn't instruct it politely asks:
> Please try to install debuginfo manually using the command:
> <b>debuginfo-install %s</b>
Again, you are twisting words - Your wording doesn't change the apparent facts.

> > Running debuginfo-install requires root => user _must_ become "root".
> > 
> > => Your statement "no. it doesn't need root!" is a lie.
> > 
> > QED.
I realize that you seem to be too close to ABRT to comprehend ABRT's severe deficiencies in usability.

> - and as usual you deliberately ignored the rest of the message... troll
> indeed...

Deliberately ignoring this utterly and impolite rudity, which alone would be sufficient reason for a formal complaint to your supervisor.

Comment 6 Jiri Moskovcak 2010-12-20 13:02:27 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #2)
> > > (In reply to comment #1)
> > > > > 
> > > > > Additional info:
> > > > > This case nicely exhibits several of the design flaws ABRT suffers from:
> > > > > - Reporting requires "root"
> > > > 
> > > > - no, it doesn't need root! I told you few times and it seems you either suffer
> > > > from serious memory loss or just want to be a troll, so one last time: only the
> > > > debuginfo-install script requires root and it's not part of ABRT it's part of
> > > > yum-utils and ABRT suggest to use it only if it's own debuginfo mechanism fails
> > > Stop twisting words - You are cheating to yourself and to your users!
> > > 
> > 
> > - what's not true on the statement above? I can easily show you the part of the
> > code in 
> > ABRT which tries to download the debuginfo and does NOT need root...
> 
> Well, then explain why it doesn't work - The screenshot is unmisunderstandably
> clear.
> 

- might be a lot of reasons even a bug in ABRT, but still doesn't mean that
ABRT requires root - it is designed to not require it.. And in this case, my guess would be a stalled mirror... (because both ABRT and debuginfo-install scripts failed even though they use a different logic to get the debuginfo..)

> > > Abrt instructs users to run "debuginfo-install"
> > > 
> > 
> > - it doesn't instruct it politely asks:
> > Please try to install debuginfo manually using the command:
> > <b>debuginfo-install %s</b>
> Again, you are twisting words - Your wording doesn't change the apparent facts.

you can see for you self:
http://git.fedorahosted.org/git/?p=abrt.git;a=blob;f=src/Daemon/abrt-debuginfo-install;h=3a236b59f5d9cc33d8195d7249471c0782718854;hb=f6a4242cd0bf9c2acb959616cd2d825fb2d927c7

> 
> > > Running debuginfo-install requires root => user _must_ become "root".
> > > 
> > > => Your statement "no. it doesn't need root!" is a lie.
> > > 
> > > QED.
> I realize that you seem to be too close to ABRT to comprehend ABRT's severe
> deficiencies in usability.
> 

- debuginfo is a long term PITA and there are some projects trying to improve the situation (as I said many times on f-d), but on top of the current infrastructure ABRT can't do much better (if you have some better idea how to deal with it, then please don't hesitate and share with us...)

> > - and as usual you deliberately ignored the rest of the message... troll
> > indeed...
> 
> Deliberately ignoring this utterly and impolite rudity, which alone would be
> sufficient reason for a formal complaint to your supervisor.

- it wasn't rude because what you're doing perfectly applies to the definition of an internet troll.. to me it seems like you only want to complain and don't really care about my answers in bugzilla and on f-d explaining this issue, so I don't really understand why you've opened this bz, if you're going to ignore any explanation I give you... 

- so either you can help us find out why ABRT failed to generate a good backtrace or you can just keep complaining that "it has design flaws", so what's it going to be?

Comment 7 Ralf Corsepius 2010-12-20 13:41:08 UTC
This discussion doesn't lead anywhere.

IMO, it's very obvious that ABRT in its present shape is not end-user ready.

It would be consequent to remove it from Fedora or at least to remove it from the default set of packages.


Note You need to log in before you can comment on or make changes to this bug.