Bug 66443 - find-requires detects wrong interpreter for awk
Summary: find-requires detects wrong interpreter for awk
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-10 18:40 UTC by OZAWA Sakuro
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-10 18:40:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description OZAWA Sakuro 2002-06-10 18:40:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020608

Description of problem:
if an executable awk script begins with
BEGIN
line, find-requires condisders BEGIN as its interpreter name.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Contain an awk script that begins its first line with BEGIN block.
2. chmod +x it.
3. Package it.
	

Actual Results:  find-requires detects the word BEGIN as an interpreter name.

Expected Results: BEGIN should not be detected because the script does not
begins with #! lne, it begins with BEGIN line though.

Additional info:

Of cource such script should not be chmod +x'ed, but find-requires should also
avoid considerering such files as executables, because these files does not
begins with #!.

Comment 1 Jeff Johnson 2002-06-12 15:22:15 UTC
Do
	chmod -x
to prevent find-requires/find-provides from
attempting to extract dependencies.


Note You need to log in before you can comment on or make changes to this bug.