Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 664431 - Sent messages folder not configured by default results in an error on send
Summary: Sent messages folder not configured by default results in an error on send
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 14
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 12:11 UTC by Jeff Clough
Modified: 2010-12-21 10:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-21 10:00:54 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 637727 0 None None None Never

Description Jeff Clough 2010-12-20 12:11:26 UTC
Description of problem:

Evolution as shipped with Fedora 14 does not have a "Sent Messages Folder" configured under "Defaults" in the account options screen.  This causes a somewhat confusing error to appear when sending an email message.  Sent messages will still go on to their intended destination, and the message will be appended to the "Sent" folder, but the error message persists until the user goes into their account setup and sets a reasonable value.

Version-Release number of selected component (if applicable):  Evolution 2.32.1

Steps to Reproduce:
1.  Begin with a clean install of Evolution.
2.  Enter your account details (note under "Defaults" the folder is not set.
3.  Send a message, see the error.
  
Actual results:  An error message appears on the screen that may lead the user to believe their message did not go through or that they did something wrong.

Expected results:  No error message since Evolution should set a reasonable default value for this setting and/or not complain when it's going to fall-back on the "Sent" folder anyway.

Comment 1 Milan Crha 2010-12-21 10:00:54 UTC
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=637727


Note You need to log in before you can comment on or make changes to this bug.