Bug 664446 - Process /usr/bin/abrt-applet was killed by signal 11 (SIGSEGV)
Summary: Process /usr/bin/abrt-applet was killed by signal 11 (SIGSEGV)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 13:14 UTC by Martin Kho
Modified: 2015-02-01 22:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-29 13:14:36 UTC


Attachments (Terms of Use)
Coredump (uploaded with Kongueror :-)) (2.06 MB, application/x-core)
2010-12-20 13:18 UTC, Martin Kho
no flags Details
yum updates from December 17th. (4.33 KB, text/plain)
2010-12-20 13:23 UTC, Martin Kho
no flags Details
gdb output (36.66 KB, application/octet-stream)
2010-12-22 23:08 UTC, Martin Kho
no flags Details

Description Martin Kho 2010-12-20 13:14:48 UTC
Description of problem:
When running abrt-gui as user - not as root! - the program seg. faults. This starts happening after the updates from Dec. 17th. At the same moment Python also crashes.

a. dmesg contains the following message:
abrt-applet[1487]: segfault at 7fcdecd06ff0 ip 000000300fd319b8 sp 00007fff54ec3428 error 4 in libc-2.12.90.so[300fc00000+19a000]
b. abrt created the following info:
analyzer: CCpp
architecture: x86_64
cmdline: /usr/bin/abrt-applet
component: abrt
description: abrt's gui
executable: /usr/bin/abrt-applet
hostname: ps-1866.localdomain
kernel: 2.6.37-0.rc6.git0.1.fc15.x86_64
package: abrt-gui-1.1.14-1.fc15
reason: Process /usr/bin/abrt-applet was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1292698566
uid: 500

c. coredump attached (I tried to add the attachment, but firefox crashed ;-( I hope to upload the coredump soon)

How reproducible:
run abrt-gui from the command prompt in the KDE GUI (konsole

Actual results:
abrt-gui seg. faults.

Expected results:
abrt-gui starts.

Additional info:

Comment 1 Martin Kho 2010-12-20 13:18:54 UTC
Created attachment 469754 [details]
Coredump (uploaded with Kongueror :-))

Comment 2 Martin Kho 2010-12-20 13:23:07 UTC
Created attachment 469755 [details]
yum updates from December 17th.

Comment 3 Martin Kho 2010-12-22 23:08:38 UTC
Created attachment 470335 [details]
gdb output

To create the report I've run:

gdb /usr/bin/python

(gdb) run /usr/share/abrt/CCMainWindow.py "$@"

(gdb) thread  apply all bt full


Martin Kho

Comment 4 Martin Kho 2010-12-23 19:52:28 UTC
Hi,

Today's updates solved this issue. Please close this report.

Martin Kho


Note You need to log in before you can comment on or make changes to this bug.