Bug 664474 - calls to i2d_X509 when certificate_blob_size is unsigned
Summary: calls to i2d_X509 when certificate_blob_size is unsigned
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ecryptfs-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 14:48 UTC by Sami Farin
Modified: 2011-01-17 20:56 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-04 13:42:37 UTC


Attachments (Terms of Use)

Description Sami Farin 2010-12-20 14:48:24 UTC
Description of problem:
in src/key_mod/ecryptfs_key_mod_pkcs11_helper.c, expression
  if ((subgraph_key_ctx->pkcs11h_data.certificate_blob_size = i2d_X509 (x509, NULL)) < 0  )
is never true because certificate_blob_size is unsigned.

Version-Release number of selected component (if applicable):
84

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Hlavinka 2011-01-04 13:25:21 UTC
thanks, fixed in ecryptfs-utils-84-2.fc* with -Wtype-limits added to build options which should (together with -Werror) prevent this in future

Comment 2 Fedora Update System 2011-01-04 14:50:53 UTC
ecryptfs-utils-84-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ecryptfs-utils-84-2.fc13

Comment 3 Fedora Update System 2011-01-04 14:51:00 UTC
ecryptfs-utils-84-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ecryptfs-utils-84-2.fc14

Comment 4 Fedora Update System 2011-01-17 20:53:09 UTC
ecryptfs-utils-84-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-01-17 20:56:34 UTC
ecryptfs-utils-84-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.