Bug 664508 - Xserver crashes with 1x1x1 bpp pixmap with error "exaGetPixmapFirstPixel called for invalid bpp 1"
Summary: Xserver crashes with 1x1x1 bpp pixmap with error "exaGetPixmapFirstPixel call...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 14
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 15:48 UTC by Olivier Fourdan
Modified: 2018-04-11 16:46 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-server-1.9.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-21 07:30:21 UTC


Attachments (Terms of Use)
suggested patch (643 bytes, patch)
2010-12-21 10:41 UTC, Matěj Cepl
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 24703 None None None Never

Description Olivier Fourdan 2010-12-20 15:48:18 UTC
Description of problem:

When using 1x1x1bpp pixmaps the Xserver chrashes with:

    exaGetPixmapFirstPixel called for invalid bpp 1  

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.9.1-3.fc14

How reproducible:

Always

Steps to Reproduce:

1. Use Xfce with ATI or Nouveau driver
2. Select Preferences->window manager
3. Select the window manager theme "Wildbush" 
  
Actual results:

X server crashes

Expected results:

No X server crash

Additional info:

This is bug 24703 upstream:

    https://bugs.freedesktop.org/show_bug.cgi?id=24703

Patch is attached to the upstream bugzilla, tested locally to fix the issue.

The problem is quite severe because one the theme is selected, it's applied each time the user logs in, and therefore the user can't log in xfce anymore (each attempt leads to an X server crash).

Comment 1 Matěj Cepl 2010-12-21 10:41:34 UTC
Created attachment 469949 [details]
suggested patch

Comment 2 Fedora Update System 2011-02-09 17:49:29 UTC
xorg-x11-server-1.9.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.4-1.fc14

Comment 3 Fedora Update System 2011-02-10 21:28:41 UTC
xorg-x11-server-1.9.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.4-1.fc14

Comment 4 Fedora Update System 2011-02-21 07:30:16 UTC
xorg-x11-server-1.9.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.