Bug 664533 - ACPI Issue - Battery not detected on 64 bit Toshiba Satellite L650-BT2N23
Summary: ACPI Issue - Battery not detected on 64 bit Toshiba Satellite L650-BT2N23
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: acpi
Version: 14
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-20 17:27 UTC by rvish07
Modified: 2012-08-16 20:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 20:39:28 UTC


Attachments (Terms of Use)
Contains response from commands such as dmesg and acpi (2.07 KB, text/plain)
2010-12-20 17:27 UTC, rvish07
no flags Details
Output from lshw (20.52 KB, application/octet-stream)
2010-12-21 17:53 UTC, rvish07
no flags Details

Description rvish07 2010-12-20 17:27:29 UTC
Created attachment 469818 [details]
Contains response from commands such as dmesg and acpi

Description of problem:
------------------------

On 64 bit Toshiba Satellite L650-BT2N23 (core i3) laptop with Fedora 14 (kernel 2.6.35.6-45.fc14.x86_64) installed, the battery is not detected. Linux can be started on battery, but the power management applet only indicates AC power (no battery). Windows 7 on a separate partition detects the battery and allows power management features normally.

Setting acpi=force or acpi=on does not remedy the problem.

Attachment shows responses from various commands such as dmesg and acpi.


How reproducible:
-----------------
Happens every time.


Steps to Reproduce:
--------------------
1. Install Fedora 14 (kernel 2.6.35.6-45.fc14.x86_64) on 64 bit Toshiba Satellite L650-BT2N23 (core i3) laptop 
2. Boot Linux on battery power and start Power Management
3. On "General" tab in Power Management settings, select "Always display an icon" under Notification Area
4. Notification area shows AC power source instead of battery
  
Actual results:
----------------
Battery not detected. Power Management indicates AC power

Expected results:
------------------
Battery should be detected and Power Management capabilities for battery should be enabled.

Additional info:
-----------------
Attachment shows responses from various commands such as dmesg and acpi.

Comment 1 rvish07 2010-12-21 17:53:28 UTC
Created attachment 470040 [details]
Output from lshw

Additional information:

'lshw' returns some battery related information, linux still does not recognize battery. The entire lshw response is attached.

<snippet>
  *-battery
       description: Lithium Ion Battery
       product: CRB Battery 0
       vendor: -Virtual Battery 0-
       physical id: 2
       version: 10/12/2007
       serial: Battery 0
       slot: Fake
</snippet>

BIOS details: Insyde H2O BIOS Version 1.70.

Comment 2 rvish07 2010-12-23 16:56:49 UTC
Some updates (still no joy):

Tried the following, but nothing worked:

1. Set the acpi=copy_dsdt flag in grub.conf, but did not solve the problem.

2. Tried rebuilding the kernel (2.6.35.6-45.fc14.x86_64) from source rpm with the acpi patch described here - https://bugzilla.kernel.org/show_bug.cgi?id=14679, but that did not resolve the problem. On the rebuilt kernel, the battery is still not detected (no power management feaures).

Comment 3 Georg Greve 2011-01-01 12:35:33 UTC
On IBM/Lenovo Thinkpad X61s with FC14 x86_64 I have issues that are may be related. 

lshw shows the battery

  *-battery
       product: 93P5030
       vendor: SONY
       physical id: 1
       slot: Rear
       capacity: 65120mWh
       configuration: voltage=14.8V

and so does cat /proc/acpi/battery/BAT0/state 

present:                 yes
capacity state:          ok
charging state:          charged
present rate:            0 mW
remaining capacity:      60930 mWh
present voltage:         16576 mV

but the battery applet in KDE shows the battery as missing, and the power management configuration reports no power management capabilities of the machine despite ACPI presenting information on the CPU in /proc/acpi/processor/CPU0/info 

processor id:            0
acpi id:                 0
bus mastering control:   no
power management:        yes
throttling control:      yes
limit interface:         yes

While the machine was able to do suspend to ram and disk as well as other power management activities under FC14 i386 without problems, after the reinstall to FC14 x86_64, none of these work anymore.

Comment 4 Fedora End Of Life 2012-08-16 20:39:31 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.