Bug 664565 - CoreUI needs to not cache certain login elements - user cannot navigate to installer on a new build.
CoreUI needs to not cache certain login elements - user cannot navigate to in...
Status: CLOSED DUPLICATE of bug 617729
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-12-20 14:21 EST by Corey Welton
Modified: 2010-12-20 14:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-20 14:29:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-12-20 14:21:01 EST
Description of problem:
This is a confusing issue to describe, but it'll be critical to fix, if not for the next future release of JON, but the one after that.  It will drive users batty.

If a user installs a GWT version of JON/RHQ (say, build x) deletes it to install a new version (say, build x+1), the browser gets confused and always attempts to redirect to the login page -- even though of course the login page does not exist on a not-yet-installed version of JON/RHQ.  

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.  Install a gwt build of RHQ/JON  (build "x")
2.  Login to new instance on example.com:7080 
3.  Shut it down and remove it.
4.  Install a newer version of RHQ/JON 
5.  Attempt to navigate to example.com:7080
  
Actual results:
User is redirected (presumably because of browser cache) to login page. This of course does not exist so user gets an error.  User cannot browse back to the installer page.

Expected results:
User is taken to the installer page.

Additional info:
The workaround, at least for Firefox, is to clear browser cache AND history.  Users will not want to do this.

Chrome is even more difficult, but we're not supporting chrome right now, so not a big deal.  I think fixing it for firefox will fix it for chrome as well.

Users may or may not run into this going from, say JON 2.4 to a future release, but if we don't fix it now, they will most certainly run into it going from whatever the next release is to one that comes after that
Comment 1 Corey Welton 2010-12-20 14:29:24 EST

*** This bug has been marked as a duplicate of bug 617729 ***

Note You need to log in before you can comment on or make changes to this bug.