Bug 664581 - subscription-manager clean module needs proxy options? I don't think so.
Summary: subscription-manager clean module needs proxy options? I don't think so.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Adrian Likins
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-20 20:14 UTC by John Sefler
Modified: 2011-05-19 13:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description John Sefler 2010-12-20 20:14:42 UTC
Description of problem:
subscription-manager clean --help shows the proxy command line options as an available option.  I do NOT believe that the clean module has any need for proxy options.

[root@jsefler-onprem01 ~]# subscription-manager clean --help
Usage: subscription-manager clean [OPTIONS]

removes all local consumer data, does not effect the server.

Options:
  -h, --help            show this help message and exit
  --debug=DEBUG         debug level
  --proxy=PROXY_URL     proxy url in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for http proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for http proxy with basic authentication




Version-Release number of selected component (if applicable):
[root@jsefler-onprem01 ~]# rpm -q subscription-manager
subscription-manager-0.93.6-1.git.0.833aab2.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem01 ~]# subscription-manager clean --proxy=kjhkjlkjh
All local data removed

^^^^ NOTICE THAT THE SPECIFIED proxy VALUE IS CLEARLY IGNORED...  BECAUSE clean DOES NOT NEED A PROXY TO CLEAN ALL LOCAL DATA.

Comment 2 Justin Harris 2011-01-03 17:26:14 UTC
In commit:  cb7358698e5685bbb14d3190fc34341e4174c75f

Comment 3 John Sefler 2011-01-04 15:15:56 UTC
[root@jsefler-onprem01 ~]# rpm -q subscription-manager
subscription-manager-0.93.8-1.git.16.cb73586.el6.x86_64

[root@jsefler-onprem01 ~]# subscription-manager clean --help
Usage: subscription-manager clean [OPTIONS]

removes all local consumer data, does not effect the server

Options:
  -h, --help     show this help message and exit
  --debug=DEBUG  debug level
[root@jsefler-onprem01 ~]# subscription-manager clean --proxy=asdfqwfqwf
Usage: subscription-manager clean [OPTIONS]

subscription-manager: error: no such option: --proxy
[root@jsefler-onprem01 ~]# 


MOVING TO VERIFIED...

Comment 4 errata-xmlrpc 2011-05-19 13:38:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.