Bug 664650 - Run virsh dump --crash cdrom_test cdrom_test.crash failed
Summary: Run virsh dump --crash cdrom_test cdrom_test.crash failed
Keywords:
Status: CLOSED DUPLICATE of bug 619846
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-21 05:45 UTC by koka xiong
Modified: 2011-01-25 12:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-25 12:32:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
the libvirtd_debug log (590.89 KB, text/plain)
2010-12-21 09:29 UTC, koka xiong
no flags Details

Description koka xiong 2010-12-21 05:45:39 UTC
error: Failed to core dump domain cdrom_test to cdrom_test.crash
error: operation failed: Migration unexpectedly failed

Version-Release number of selected component (if applicable):
libvirt-0.8.1-27.el6_0.2.x86_64
qemu-kvm-0.12.1.2-2.113.el6_0.5.x86_64
kernel-2.6.32-71.13.1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.virsh dumpxml cdrom_test
<domain type='kvm' id='4'>
  <name>cdrom_test</name>
  <uuid>e85e2a17-06f2-5dbe-677a-d6a90e341971</uuid>
  <memory>1048576</memory>
  <currentMemory>1048576</currentMemory>
  <vcpu>2</vcpu>
  <os>
    <type arch='x86_64' machine='rhel6.0.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/var/lib/libvirt/images/cdrom_test.img'/>
      <target dev='hda' bus='ide'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    </disk>
    <disk type='block' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source dev='/dev/sr0'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <alias name='ide0-1-0'/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <interface type='network'>
      <mac address='52:54:00:2f:1d:cb'/>
      <source network='default'/>
      <target dev='vnet0'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/1'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='pty' tty='/dev/pts/1'>
      <source path='/dev/pts/1'/>
      <target port='0'/>
      <alias name='serial0'/>
    </console>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5900' autoport='yes' keymap='en-us'/>
    <sound model='ac97'>
      <alias name='sound0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </sound>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <alias name='balloon0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </memballoon>
  </devices>
  <seclabel type='dynamic' model='selinux'>
    <label>system_u:system_r:svirt_t:s0:c802,c988</label>
    <imagelabel>system_u:object_r:svirt_image_t:s0:c802,c988</imagelabel>
  </seclabel>
</domain>
2.virsh start cdrom
3.virsh dump --crash cdrom_test cdrom_test.crash
  
Actual results:
error: Failed to core dump domain cdrom_test to cdrom_test.crash
error: operation failed: Migration unexpectedly failed

Comment 1 koka xiong 2010-12-21 06:00:24 UTC
tail -f /var/log/messages
Dec 21 13:59:44 kxiong libvirtd: 13:59:44.021: error : qemuDomainWaitForMigrationComplete:5426 : operation failed: Migration unexpectedly failed

Comment 2 koka xiong 2010-12-21 09:29:20 UTC
Created attachment 469938 [details]
the libvirtd_debug log

Comment 5 Osier Yang 2011-01-25 12:32:58 UTC
It's caused by qemu-kvm process is of qemu:qemu, and you tried to dump the image
to /root, where qemu:qemu doesn't have permission to write.

the cause is same with #BZ https://bugzilla.redhat.com/show_bug.cgi?id=619846

*** This bug has been marked as a duplicate of bug 619846 ***


Note You need to log in before you can comment on or make changes to this bug.