Bug 664701 - xorg-x11-fonts-update-dirs should be silent
Summary: xorg-x11-fonts-update-dirs should be silent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-font-utils
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matěj Cepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-21 12:15 UTC by Ralf Corsepius
Modified: 2018-04-11 12:50 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-font-utils-7.4-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-25 00:25:48 UTC


Attachments (Terms of Use)
suggested patch (436 bytes, patch)
2010-12-21 14:38 UTC, Matěj Cepl
no flags Details | Diff

Description Ralf Corsepius 2010-12-21 12:15:36 UTC
Description of problem:

xorg-x11-fonts-update-dirs is not silent. It contains pushd+popd calls which echo directories to stdout.


Version-Release number of selected component (if applicable):
xorg-x11-font-utils-7.4-3.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. login as root
2. cd ~
3. run 
xorg-x11-fonts-update-dirs --skip-fontscale /usr/share/X11/fonts/misc
  
Actual results:

# xorg-x11-fonts-update-dirs --skip-fontscale /usr/share/X11/fonts/misc
/usr/share/X11/fonts/encodings ~
~

Expected results:
Silence/No output

Additional info:
- As xorg-x11-fonts-update-dirs is used in rpm scriptlets, this issue causes rpm-installation of font-packages to be non-silent - This violates the FPG.
- There are 2 ways to silence pushd/popd.
pushd -n <dir> and pushd <dir> >/dev/null.
The latter is better portable, because not all shells' pushd/popd implementations support "-n" (e.g. zsh's doesn't).

Comment 1 Matěj Cepl 2010-12-21 14:38:32 UTC
Created attachment 469993 [details]
suggested patch

I think the patch is completely trivial. What do you think?

Comment 2 Matěj Cepl 2010-12-21 14:40:57 UTC
damn! Wrong tab. It should go to bug 664699 of course.

Comment 3 Matěj Cepl 2010-12-22 12:27:27 UTC
Rawhide build http://koji.fedoraproject.org/koji/taskinfo?taskID=2683873

Comment 4 Fedora Update System 2010-12-22 13:36:20 UTC
xorg-x11-font-utils-7.4-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-font-utils-7.4-4.fc14

Comment 5 Fedora Update System 2010-12-22 19:54:07 UTC
xorg-x11-font-utils-7.4-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-font-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-font-utils-7.4-4.fc14

Comment 6 Fedora Update System 2010-12-25 00:25:39 UTC
xorg-x11-font-utils-7.4-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.