Bug 66476 - printcap parsing broken
printcap parsing broken
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: samba (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-10 21:49 EDT by kenneth_porter
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-10 21:51:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kenneth_porter 2002-06-10 21:49:46 EDT
samba-2.4.4-3 from Red Hat Rawhide

Using the following simple printcap file (one line,  many 
aliases), only 
one printer is visible from a Win2k client with "net view \\server", the 

Optra45n_1.

lp|Lexmark|lp2|HPLJ4V|lp3|Optra45n_1|lp4

If I change this to remove 
the pipe separators and put each printer name on 
a line by itself, the net command reveals all 
seven printer names.
Comment 1 kenneth_porter 2002-06-10 21:51:52 EDT
BTW, I'm using printing=lprng.
Comment 2 Trond Eivind Glomsrxd 2002-07-09 16:49:02 EDT
That's not a bug - it displays only the primary name, but you can connect to all
of them by explicit name.

Note You need to log in before you can comment on or make changes to this bug.