Bug 664775 - rhsm in firstboot ignores proxy
Summary: rhsm in firstboot ignores proxy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-21 15:52 UTC by J.C. Molet
Modified: 2013-01-10 10:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2010-12-21 15:52:59 UTC
Description of problem:
When registering in rhsm during firstboot, the connection will ignore the proxy even if one is selected, and will attempt to directly connect to the candlepin server.


Version-Release number of selected component (if applicable):
subscription-manager-0.93.7-1.git.3.fbdf967.el6.x86_64
subscription-manager-gnome-0.93.7-1.git.3.fbdf967.el6.x86_64


Steps to Reproduce:
1. Install subscription manager and all its deps on a rhel6 server
2. run firstboot
3. Hit Forward
4. Select "Register with Red Hat Entitlement Service" and hit Forward
5. Enter in your candlepin user/pass (on the 'Entitlement Registration' step)
6. Select Proxy Configuration, and enter in the information to your proxy.
7. Hit Forward.
  
Actual results:
The registration ignores the proxy settings and tries to connect directly to the  candlepin server, bypassing the proxy.  The rhsm.log shows that a direct connection was made, and the proxy server log doesn't log any access requests.

Expected results:
The connection would be made through the proxy.

Comment 2 Adrian Likins 2011-01-05 19:21:48 UTC
I have a potential fix for this. I say potential, because I haven't actually reproduced this in firstboot, but could trigger something similar in the gui (and 
it feels like the same issue).


commit e79dad86b72a8824d6129ede3a7680ce2ee22659
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Jan 5 14:16:39 2011 -0500

    664775: potential fix for proxy being ignored in firstboot
    
    In the gui, the admin uep wasn't getting created with proxy info,
    so wasn't being used for registration. Fix that, as well as cleaning
    up some of the Backend() code for sharing of uep's.

Comment 3 J.C. Molet 2011-01-05 21:49:55 UTC
subscription-manager-gnome-0.93.9-1.git.15.3545a2a.el6.x86_64
subscription-manager-0.93.9-1.git.15.3545a2a.el6.x86_64
python-rhsm-0.94.10-1.git.3.8361c7e.el6.noarch
subscription-manager-firstboot-0.93.9-1.git.15.3545a2a.el6.x86_64
rhn-setup-gnome-1.0.0-41.el6.noarch

Fixed as tested with above versions ^

Comment 4 errata-xmlrpc 2011-05-19 13:38:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.