Bug 664778 - /dev/fuse is not getting a label.
/dev/fuse is not getting a label.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: udev-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-21 10:59 EST by Daniel Walsh
Modified: 2011-10-21 06:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 06:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2010-12-21 10:59:38 EST
It is being labeled device_t?
Comment 1 Harald Hoyer 2011-01-20 03:09:10 EST
(In reply to comment #0)
> It is being labeled device_t?

Hmm, udev does not have a hardcoded exception for this device... so?
Comment 2 Daniel Walsh 2011-01-20 09:55:46 EST
Well something is going wrong.  It is still wrong in rawhide.
Comment 3 Harald Hoyer 2011-01-20 10:05:36 EST
/lib/udev/devices/fuse is copied to /dev/fuse at startup until someone accesses /dev/fuse. Then the fuse module is loaded.
Comment 4 Harald Hoyer 2011-01-20 10:06:17 EST
most likely /lib/udev/devices/* need a proper label, too
Comment 5 Harald Hoyer 2011-01-20 10:06:49 EST
or the copy process does not honor selinux labels.
Comment 6 Daniel Walsh 2011-01-20 16:33:52 EST
matchpathcon /lib/udev/devices/fuse 
/lib/udev/devices/fuse	system_u:object_r:fuse_device_t:s0


The copy command needs to be made SELinux aware.  Or use cp -A
Comment 7 Harald Hoyer 2011-01-21 10:48:51 EST
Might need this patch, I created because of this bug:
http://marc.info/?l=linux-hotplug&m=129562438114594&w=2
Comment 8 Harald Hoyer 2011-01-21 11:41:27 EST
oh, ok... does this fix the issue in rawhide?

# rm /lib/udev/devices/fuse
Comment 9 Fedora Admin XMLRPC Client 2011-10-20 12:08:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2011-10-20 12:10:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Fedora Admin XMLRPC Client 2011-10-20 12:12:42 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora Admin XMLRPC Client 2011-10-20 12:17:09 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.