Bug 664779 - firstboot register dialog opens with incorrect size.
Summary: firstboot register dialog opens with incorrect size.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-21 16:01 UTC by J.C. Molet
Modified: 2013-01-10 10:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
firstboot register pop up (222.05 KB, image/png)
2010-12-21 16:02 UTC, J.C. Molet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2010-12-21 16:01:57 UTC
Description of problem:
When in firstboot, at the "RHSM Subscription Management" screen, if you click on the "register system" button, the register dialog opens in a very small window that cannot be resized, and the content cannot be viewed.

Version-Release number of selected component (if applicable):
subscription-manager-0.93.7-1.git.3.fbdf967.el6.x86_64
subscription-manager-gnome-0.93.7-1.git.3.fbdf967.el6.x86_64

Steps to Reproduce:
1. Install subscription-manager and all its deps on a rhel6 server
2. run firstboot.
3. Hit forward, register using entitlements, until you reach the "RHSM Subscription Management" screen
4. Click 'Unregister System'
5. Click 'Register System'
  
Actual results:
The 'register system' dialog opens in an extremely small window that cannot be resized.

Expected results:
the register system dialog opens normally as in the normal subscription-manager-gui

Additional info:
see attached screenshot.

Comment 1 J.C. Molet 2010-12-21 16:02:46 UTC
Created attachment 470015 [details]
firstboot register pop up

Comment 2 James Bowes 2011-01-05 14:11:38 UTC
Since this is firstboot and you've just registered, how about we either hide the unregister button, or grey it out?

Comment 3 J.C. Molet 2011-01-05 14:50:54 UTC
I think Hiding this button in firstboot would be cleaner... as long as you can hit the back button and register as another user (ie, clicking 'forward' on the register screen would be the equivalent of: subscription manager register --user=foo --password=bar --force), much of the functionality would be retained.

Comment 4 James Bowes 2011-01-05 14:54:47 UTC
cool, i'll do that.

Comment 6 J.C. Molet 2011-01-06 14:27:29 UTC
This is working as tested in this version:

subscription-manager-firstboot-0.93.9-1.git.15.3545a2a.el6.x86_64
subscription-manager-0.93.9-1.git.15.3545a2a.el6.x86_64
subscription-manager-gnome-0.93.9-1.git.15.3545a2a.el6.x86_64

Comment 7 errata-xmlrpc 2011-05-19 13:38:25 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.