Bug 664784 - Guest crash when host has >= 64G RAM
Summary: Guest crash when host has >= 64G RAM
Keywords:
Status: CLOSED DUPLICATE of bug 616827
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 448115
Blocks: 504988
TreeView+ depends on / blocked
 
Reported: 2010-12-21 16:22 UTC by Qixiang Wan
Modified: 2010-12-23 18:06 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 448115
Environment:
Last Closed: 2010-12-23 18:06:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
config file for the guest (424 bytes, text/plain)
2010-12-21 16:32 UTC, Qixiang Wan
no flags Details
xm dmesg on host (16.00 KB, text/plain)
2010-12-21 16:32 UTC, Qixiang Wan
no flags Details
host dmesg log (60.13 KB, text/plain)
2010-12-21 16:33 UTC, Qixiang Wan
no flags Details
32 pv guest boot log (7.16 KB, text/plain)
2010-12-21 16:34 UTC, Qixiang Wan
no flags Details

Comment 6 Paolo Bonzini 2010-12-22 09:36:01 UTC
Next time, please test with the -133 kernel on the same host before adding the regression keyword.  Can you do this test now?

I don't think Xen was ever tested with such huge hosts, it's very likely that this is a different bug.

Comment 7 Andrew Jones 2010-12-22 12:20:04 UTC
(In reply to comment #6)
> Next time, please test with the -133 kernel on the same host before adding the
> regression keyword.  Can you do this test now?
> 
> I don't think Xen was ever tested with such huge hosts, it's very likely that
> this is a different bug.

Indeed. Has anyone every tried what I suggested in bug 524624 comment 42? Which is to specify mem=512G on the xen.gz command line? The HV can only use up to 512G of memory, so there's a chance it just gets confused if there's more.

Comment 8 Qixiang Wan 2010-12-22 15:06:08 UTC
tried with mem=256G on xen.gz command line, and turn off ballooning, guest still crash (host: 2.6.18-238.el5xen 64bit, guest: 2.6.18-194.el5xen 32bit).

tried to boot up -133 kernel on the host, host crash during boot. I'll try to find other machines to have a check with above issues.

Comment 9 Andrew Jones 2010-12-23 14:32:48 UTC
Using a machine that really has only 256G of memory, and not just trying to use mem=256G on a 1T machine works for my rhel5.6-beta (2.6.18-229.el5xen) guest. I don't believe we have a regression here. We're just attempting to test on hardware that hasn't been attempted before.

Comment 12 Andrew Jones 2010-12-23 18:06:22 UTC
My comment 9 was for 64-bit guests. Sorry, I missed that this bug was also for
32-bit guests. Since the host has >=168G then this is really a dup of bug 616827. We don't need to go all the way back to fixing the >=64G issue. As bug 616827 is
still ON_QA, I'll dup this over there to clean things up a bit.

I have found that I can no longer install rhel5 32-bit guests on the same 256G machine that I previously verified that other bug on, so I'm looking into the issue. See further comments in that bug.

*** This bug has been marked as a duplicate of bug 616827 ***


Note You need to log in before you can comment on or make changes to this bug.