Bug 664806 - Nautilus does not launch applications by mimetype when configured
Summary: Nautilus does not launch applications by mimetype when configured
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-21 17:50 UTC by Paul Lambert
Modified: 2015-03-03 22:56 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-20 19:55:58 UTC


Attachments (Terms of Use)
application propterties assigned to mimetype .drf (56.33 KB, image/png)
2010-12-21 17:50 UTC, Paul Lambert
no flags Details

Description Paul Lambert 2010-12-21 17:50:09 UTC
Created attachment 470039 [details]
application propterties assigned to mimetype .drf

Description of problem:  I have created an application drfLaunch and configured Nautilus to launch any file with the suffix .drf with drfLaunch.  The target files contain ASCII data, and therefore, are created as text/plain.  When I set this up it works as expected but if I double click a .txt file it also launches drfLaunch instead of gedit. 


Version-Release number of selected component (if applicable): Fe-14 and prior


How reproducible:  


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:  I would expect Nautilus to retain the configuration for each mimetype (suffix) so that any file with .txt launches gedit as the default and any other user files such as .drf to launch the application configured to the mimetype.  


Additional info:

Comment 1 Fedora Update System 2011-01-11 01:22:48 UTC
nautilus-actions-3.0.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/nautilus-actions-3.0.6-1.fc14

Comment 2 Fedora Update System 2011-01-12 05:26:49 UTC
nautilus-actions-3.0.6-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-actions'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/nautilus-actions-3.0.6-1.fc14

Comment 3 Fedora Update System 2011-01-20 19:55:47 UTC
nautilus-actions-3.0.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Paul Lambert 2011-01-20 20:24:18 UTC
Nautilus-actions-3.0.6-1.fc14 is installed.  I open properties for a file with mimetype .txt and select open with gedit.  I double click the document icon and it opens correctly.  I then go to a file with mimetype .drf and select open it with drflaunch.  I double click the doucment and it opens correctly with drflaunch.  I then go back to the first .txt file and open properties.  It is configured to open with drflaunch and not as I originally configured with gedit.  There is no change in the status of this first bug report.  Nautilus is not using the assigned launch property by mimetype but rather by plain/text file type.

Should be by mimetype.  

.txt     gedit
.drf     drflaunch

Comment 5 Deji Akingunola 2011-01-20 22:07:18 UTC
This particular bug seems to belong to nautilus proper, re-assigning.

Comment 6 Paul Lambert 2011-04-09 01:32:53 UTC
ping.  Any update?  Still experience same problem with nautilus-actions.x86_64 3.0.6-1.fc14


Note You need to log in before you can comment on or make changes to this bug.