Bug 664930 - Tracker: Script to prevent/address flex guest activation issue when upgrading to RHN Satellite 5.4
Tracker: Script to prevent/address flex guest activation issue when upgrading...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Martin Minar
:
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-12-22 01:47 EST by Xixi
Modified: 2016-07-03 20:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Several things adding to the cause: virtual guests might been recognized as physical systems, guest entitlements being consumed by physical systems and certain multi-organizational entitlement allocation schemas with insufficient entitlements in base organization. Consequence: Activation of a new Satellite certificate would fail. Fix: Updated Satellite upgrade instructions and a script to check potential problems with a new Satellite certificate as a part of upgrade procedure. The script will inform of potential activation problems and recommended courses of action. Result: Activation of new Satellite certificate following updated upgrade instructions will succeed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 16:19:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2010-12-22 01:47:25 EST
Description of problem:
There's an issue involving flex guest entitlements when upgrading to Satellite 5.4 that may cause Satellite certificate activation to fail.  This Bugzilla is to track the development. availability & customer usage of a pre-upgrade script that helps identify potential entitlement issues that would prevent Satellite 5.4 activation, allowing the user to address them prior to beginning the upgrade.  It can also be run on post-upgrade 5.4 Satellites to help migrate flex guests to their proper entitlements without having to re-register.

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.4.0

How reproducible:
Always.

Steps to Reproduce:

Actual results:

Expected results:

Additional info:
Engineering is working on it. More details in internal tracker/spec pages.
Comment 3 Justin Sherrill 2011-01-03 09:12:53 EST
Here is what has been done:

New scripts in the rhn-upgrade package:


/etc/sysconfig/rhn/satellite-upgrade/entitlement-check.py
/etc/sysconfig/rhn/satellite-upgrade/recognize_guests.py

As part of the preparations.txt, a new step was added:



1. Verify that there will not be any entitlement issues during the upgrade.  Run:

/etc/sysconfig/rhn/satellite-upgrade/entitlement-check.py --rhn-cert=~/new.cert

where ~/new.cert is the path to the new entitlement certificate you will use
during the upgrade (this was requested in step #1 above)

This will check your entitlement usage and organizational distributions to ensure there should not be an issue while upgrading.  If an issue is discovered, the script will give you instructions on how to correct the issue.  This may involve contact Global Support Services. The script may also detect guest systems that are not currently being recognized as guests and are consuming physical entitlements.  One such example is a VMWare guest registered
on Red Hat Enterprise Linux 5.1. If that is the case, it is recommended that you run as instructed:

/etc/sysconfig/rhn/satellite-upgrade/recognize-guests.py

this will convert all guests as they are discovered.  After running this, please re-run entitlment-check.py in order to re-test the new certificate.
Comment 4 Martin Minar 2011-01-12 09:03:51 EST
Scripts are present in latest version of rhn-upgrade package, documentation is updated and when steps are performed as described in documentation it will run checks and if needed it will instruct you to run recognize-guests.py
Comment 5 Florian Nadge 2011-01-14 06:01:52 EST
Please be so kind and add a few key words to the Technical Notes of this
Bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:

For details, see:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 6 Florian Nadge 2011-01-14 06:01:52 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 8 Milan Zazrivec 2011-01-14 07:44:53 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,9 @@
-Cause:
+Cause: Several things adding to the cause: virtual guests might been recognized as physical systems, guest entitlements being consumed by physical systems and certain multi-organizational
+entitlement allocation schemas with insufficient entitlements in base organization.
 
-Consequence:
+Consequence: Activation of a new Satellite certificate would fail.
 
-Fix:
+Fix: Updated Satellite upgrade instructions and a script to check potential problems with a new Satellite certificate as a part of upgrade procedure. The script will inform of potential activation problems and recommended courses of action.
 
-Result:+Result: Activation of new Satellite certificate following
+updated upgrade instructions will succeed.
Comment 11 errata-xmlrpc 2011-01-17 16:19:45 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0155.html

Note You need to log in before you can comment on or make changes to this bug.