Bug 665014 - backport various fixes for cirrus and VNC
Summary: backport various fixes for cirrus and VNC
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.7
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 699611
TreeView+ depends on / blocked
 
Reported: 2010-12-22 13:06 UTC by Paolo Bonzini
Modified: 2011-08-03 07:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 07:15:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
backport (3.05 KB, patch)
2011-01-03 14:09 UTC, Paolo Bonzini
no flags Details | Diff
screenshot for the repro (191.22 KB, image/png)
2011-05-23 12:51 UTC, Pengzhen Cao
no flags Details
vncview.log (3.35 KB, text/plain)
2011-05-23 12:51 UTC, Pengzhen Cao
no flags Details
qemu-dm log before fix (5.30 KB, text/plain)
2011-05-23 12:52 UTC, Pengzhen Cao
no flags Details
qemu-dm log after fix (2.42 KB, text/plain)
2011-05-23 12:52 UTC, Pengzhen Cao
no flags Details

Description Paolo Bonzini 2010-12-22 13:06:27 UTC
99a5a9155284ab47eda2be738be0115aa97ce0ff
    fix vnc screen corruption bugs and viewer exits

    Fixes "rect too big" on rapidly changing output or slow connections

5a369fdfe6eeb8aa2a2cd52387bf03fed83e925c
    add two missing cirrus_update_memory_access

    Said to fix possible segfaults in qemu, safe

Comment 1 Michal Novotny 2011-01-03 13:50:05 UTC
Right, this is good to have when somebody is using VNC directly instead of virt-manager or any GTK-VNC based tool so I'm going to work on this one.

Michal

Comment 2 Paolo Bonzini 2011-01-03 14:09:04 UTC
Created attachment 471483 [details]
backport

I had started backporting the patches so here they are.  If you want to test them (Windows guests on high latency connections are good) and post them, I'm happy to pass the bug to you

Comment 4 RHEL Program Management 2011-01-11 20:13:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Program Management 2011-01-12 15:23:24 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 7 Miroslav Rezanina 2011-03-17 09:54:31 UTC
Fix built into xen-3.0.3-126.el5

Comment 9 Pengzhen Cao 2011-05-23 12:43:59 UTC
Failed for test with latest xen-3.0.3-131.el5, still can repro the "rect too big" issue with xen-131.

Procedure to verify:
1. Install host and install it with xen-125 and kernel-2.6.18-262, the last build before the fix.
2. create a winxp 32 hvm guest
3. connect to the xen host with vncviewer on my notebook which connects to the network with VNC( in order to create a low bandwidth environment of 100~400kbps),  play some animation in the windows guest, e.g. "Tour windows XP" from start menu or some movie.
4. random move the mouse in the VM and after 2~5 min, it will got "rect too big" error.

After I upgrade the xen to xen-3.0.3-131, repeat the above steps and I still can get "rect too big" error.

Please check the attached screenshot and log files

Comment 10 Pengzhen Cao 2011-05-23 12:51:11 UTC
Created attachment 500424 [details]
screenshot for the repro

Comment 11 Pengzhen Cao 2011-05-23 12:51:48 UTC
Created attachment 500425 [details]
vncview.log

Comment 12 Pengzhen Cao 2011-05-23 12:52:15 UTC
Created attachment 500426 [details]
qemu-dm log before fix

Comment 13 Pengzhen Cao 2011-05-23 12:52:51 UTC
Created attachment 500427 [details]
qemu-dm log after fix

Comment 14 Miroslav Rezanina 2011-06-01 13:00:08 UTC
As fixing the problem is not trivial and we're late in 5.7 testing phase, fixing the bug is moved to 5.8

Comment 16 Miroslav Rezanina 2011-08-03 07:15:15 UTC
Even the patch in #1 improves vnc handling, problem with too big rect still exists. Solving this issue require too invasive changes for current state of rhel xen. As this is internal reported problem, we will notfix it.


Note You need to log in before you can comment on or make changes to this bug.