Bug 665027 - ifcfg-rh: honor DEFROUTE setting in BOOTPROTO="ibft" case too
ifcfg-rh: honor DEFROUTE setting in BOOTPROTO="ibft" case too
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks: 638131
  Show dependency treegraph
 
Reported: 2010-12-22 08:29 EST by Radek Vykydal
Modified: 2011-05-19 10:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-7.el6
Doc Type: Bug Fix
Doc Text:
Configurations that used multiple network devices where one device was an iSCSI adapter that should not have the default route were incorrectly handled. This is now fixed to ensure that iSCSI devices that are denied the default route do not receive it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch with fix (1.02 KB, text/plain)
2010-12-22 08:29 EST, Radek Vykydal
no flags Details

  None (edit)
Description Radek Vykydal 2010-12-22 08:29:56 EST
Created attachment 470201 [details]
patch with fix

I came across this issue while working on bug #638131 - the use case is installing via one NIC while using iSCSI target via another NIC. I'd like to write  BOOTPROTO=ibft and DEFROUTE=no (depending on ks parameter) into iSCSI device's ifcfg file, but DEFROUTE is ignored in this case. I am attaching a patch. Or am I missing some reason for present behaviour?
Comment 2 Dan Williams 2011-01-11 10:51:33 EST
I think because the initial iSCSI support only targeted the iSCSI device as the boot device, and because with ibft the settings are stored in NVRAM and not changable.  GATEWAYDEV is a global setting though, so it isn't stored in NVRAM.  Given that GATEWAYDEV is a global, I can't think of a reason why this patch should not be applied.
Comment 3 Dan Williams 2011-01-11 10:55:39 EST
Pushed upstream:

b46cf443c05cf385cbec6e4accd9cab1a5a3a74d (master)
32b0413b508e3ac9170f9a4133e2b6dfe69acb6c (0.8.x)
Comment 4 David Cantrell 2011-01-26 10:17:24 EST
QE:  We need to get this fix included in NetworkManager in RHEL-6 for anaconda bug #638131.  We have the changes on the anaconda side, but NM still needs this fix.
Comment 9 Radek Vykydal 2011-04-01 08:55:24 EDT
I tested it here https://bugzilla.redhat.com/show_bug.cgi?id=638131#c22 from my installer needs POV and it is fixed for me - DEFROUTE=no is honoured and things work as expected.
Comment 11 Misha H. Ali 2011-04-20 03:48:40 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Configurations that used multiple network devices where one device was an iSCSI adapter that should not have the default route were incorrectly handled. This is now fixed to ensure that iSCSI devices that are denied the default route do not receive it.
Comment 12 errata-xmlrpc 2011-05-19 10:25:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0769.html

Note You need to log in before you can comment on or make changes to this bug.