Bug 66509 - anaconda leaves junk in /var/lib on failed upgrade
anaconda leaves junk in /var/lib on failed upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-11 12:18 EDT by John Reiser
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-11 23:24:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2002-06-11 12:18:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.16-KRUD-perfctr2.3.6
i586)

Description of problem:
If an upgrade install (for example, 7.2==>7.3) fails because of
fatal error (media, disk space, EPERM in rpm), then anaconda
leaves a junk directory /var/lib/anaconda-rebuilddbNNNNNNNNNN
which can contain 25MB or more of space.  Either this directory
should be removed automatically, or anaconda should give a
message about it.  [If an upgrade fails once, then chances are
it will fail a couple more times before succeeding, and
losing 25MB of disk space each time can cause a failure itself!]

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/chattr +i /bin/cp   # make immutable some file that will be upgraded
2. Attempt to upgrade; it will fail due to EPERM in rpm
3. Reboot, and look in /var/lib/anaconda*
	

Actual Results:  $ du -s /var/lib/anaconda*
24940
$ 


Expected Results:  Either: no junk in /var/lib; or, a message about it.

Additional info:
Comment 1 Michael Fulbright 2002-06-11 23:24:10 EDT
Assigning to an engineer.
Comment 2 Jeremy Katz 2002-07-02 01:35:51 EDT
We don't do rebuilds in the general case anymore, so this isn't a problem with
our current codebase.

Note You need to log in before you can comment on or make changes to this bug.