Bug 66515 - Mozilla 1.0 build (mozilla-nspr) breaks Evolution
Mozilla 1.0 build (mozilla-nspr) breaks Evolution
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-11 14:13 EDT by Scott Dowdle
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-11 14:13:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2002-06-11 14:13:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
Following the Mozilla development through 1.0rc1, rc2, and rc3 on Red Hat Linux
7.3, everything worked fine including Evolution (evolution-1.0.3-6).  Updating
to Mozilla 1.0 packages (mozilla-nspr-1.0.0-9) makes Evolution produce the
following error:

"Cannot initialize the Ximian Evolution shell: Configuration Database not found"

I'm not sure what specifically causes or fixes this problem, but generally
speaking, going back to 1.0rc3 fixes the problem.  I suspect the problem is
related to the mozilla-nspr package... as some online help I found (sorry not to
provide the link, it is long gone) pointed the figure there.  In any event,
installing the Mozilla 1.0 packages breaks Evolution, and going back to Mozilla
1.0rc3 makes it work again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Fvh the packages found here:
ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.0/Red_Hat_7x_RPMS/i386/
(packages built by Red Hat)
2. Run Evolution, it produces error
3. 
	

Actual Results:  Run Evolution, it produces error

Expected Results:  Evolution should run 

Additional info:

Attempting to run evolution from a shell reports additional error:

evolution-shell-WARNING **: Cannot access Bonobo/ConfigDatabase on wombat:
(IDL:OAF/GeneralError:1.0)
Comment 1 Christopher Blizzard 2002-06-12 11:25:37 EDT
This isn't a bug.  This change was made on purpose.  Besides, those aren't
'official' Red Hat packages.
Comment 2 Scott Dowdle 2002-06-12 12:24:57 EDT
I appreciate the speedy reply... and OK, I'll buy that.

Given the fact that Red Hat usually only updates for security and/or bug fixes,
I'd guess that there are no plans to provide official Mozilla 1.0 packages for
RHL 7.3 and that 7.3 users are recommended to use the 0.99 release?

Maybe next release... but it didn't hurt to ask.  Thanks for all of your hard work!
Comment 3 Scott Dowdle 2002-06-12 12:49:44 EDT
Updating to the Rawhide release of evolution-1.0.5-2 fixed the problem.
Comment 4 Scott Dowdle 2002-06-12 13:02:04 EDT
Nevermind... that didn't fix it.  I'll shutup now.
Comment 5 Christopher Blizzard 2002-06-12 15:29:42 EDT
I'll be releasing 1.0 packages when I feel like they are in good shape.

Note You need to log in before you can comment on or make changes to this bug.