Bug 66519 - xman complains about not being able to find any man pages
xman complains about not being able to find any man pages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-11 15:17 EDT by Peter Dawes
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-13 20:44:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Dawes 2002-06-11 15:17:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.2 (X11; Linux i686; U;) Gecko/20020510

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run xman


Actual Results:  Got error message:  Xman Error: No manual pages found.

	

Expected Results:  Expected to see the xman window.

Additional info:

I straced xman, discovered it was looking for a (non-existant)
/etc/manpath.config.  I tried linking /etc/man.config to /etc/manpath.config,
but no luck.  (Incidentally, the man page for xman says it should be looking at
/etc/man.config...).  Standard man command works fine.
Comment 1 Mike A. Harris 2002-06-13 20:44:42 EDT
This one drives me nuts.   ;o)

The problem is that XFree86 xman assumes a specific name and location for
the man config file based on the OS being used.  This is totally incorrect,
since there is no standard which dictates the name and/or location of the
man config file.  In order to ensure we are following standards, I consulted
the Linux Standard Base (LSB), the File Heirarchy Standard (FHS), and also
the Single Unix Specification version 3 (SuSv3) as well as discussing it with
Matt Wilson whom is our local expert in these sort of matters.

Aparently, /etc/manpage.configurationfile is acceptable as far as I can tell,
which is IMHO a bummer since it lacks an official standard to pin it down.

XFree86 defaults to looking for man.conf in Linux, however ours is called
man.config (and has been for ages).  We have patched this numerous times
in XFree86, however continuous changes to the files upstream have caused
it to continuously break.

IMHO, the real problem here is twofold:

1) The lack of an official standard
2) XFree86's bad assumption of the location of the config file, and lack
   of build time configurability via Imake for this.

I'm going to try to make this an Imake configuration option for once and
for all, and try to get it included in XFree86 4.3.0 stock so that we
dont have xman break every 6 months.

Thanks for reporting.
Comment 2 Mike A. Harris 2002-06-15 06:31:13 EDT
I rewrote the xman Imakefile to define MANCONF there, instead of it getting
defined in version.h, and I made the default man.conf, with an override for
both Red Hat Linux (man.config) and Debian (manpath.config).  I've sent the 
patch upstream in hopes they'll apply it and end this maddness.  ;o)

XFree86-4.2.0-xman-manconf.patch in rawhide.

Note You need to log in before you can comment on or make changes to this bug.