Bug 665336 - ixgbe driver fails due to unavailability of MMIO resource.
ixgbe driver fails due to unavailability of MMIO resource.
Status: CLOSED DUPLICATE of bug 665335
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.6
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-23 05:37 EST by srinivas gowda
Modified: 2011-01-07 14:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-07 10:17:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (48.58 KB, text/plain)
2010-12-23 05:45 EST, srinivas gowda
no flags Details
lspci -vvv (72.95 KB, text/plain)
2010-12-23 05:45 EST, srinivas gowda
no flags Details
lspci -t (683 bytes, text/plain)
2010-12-23 05:46 EST, srinivas gowda
no flags Details

  None (edit)
Description srinivas gowda 2010-12-23 05:37:21 EST
Description of problem:

The ixgbe driver reports error when driver is loaded with parameter max_vfs=1 
Original source  -  Bug 566027. 
 

Steps to Reproduce:
1.Install RHEL5.6 on  a blade server having Intel82599 Ethernet Card( SRIOV )
2. Load the ixgbe module with parameter max_vfs=1.
3. Check the dmesg for error - 
ixgbe 0000:07:00.1: not enough MMIO resources for SR-IOV
ixgbe: 0000:07:00.1: ixgbe_probe_vf: Failed to enable PCI sriov: -12

  
Actual results:
ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 2.0.84-k2
ixgbe: Copyright (c) 1999-2010 Intel Corporation.
PCI: Enabling device 0000:07:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:07:00.0[B] -> GSI 50 (level, low) -> IRQ 146
PCI: Setting latency timer of device 0000:07:00.0 to 64
ixgbe 0000:07:00.0: not enough MMIO resources for SR-IOV
ixgbe: 0000:07:00.0: ixgbe_probe_vf: Failed to enable PCI sriov: -12
ixgbe: 0000:07:00.0: ixgbe_init_interrupt_scheme: Multiqueue Enabled: Rx Queue count = 24, Tx Queue count = 24
ixgbe: 0000:07:00.0: ixgbe_probe: (PCI Express:5.0Gb/s:Width x8) 00:1b:21:6b:bc:90
ixgbe: 0000:07:00.0: ixgbe_probe: MAC: 2, PHY: 0, PBA No: e90209-006
ixgbe: eth0: ixgbe_probe: Intel(R) 10 Gigabit Network Connection
PCI: Enabling device 0000:07:00.1 (0000 -> 0002)
ACPI: PCI Interrupt 0000:07:00.1[A] -> GSI 40 (level, low) -> IRQ 163
PCI: Setting latency timer of device 0000:07:00.1 to 64
ixgbe 0000:07:00.1: not enough MMIO resources for SR-IOV
ixgbe: 0000:07:00.1: ixgbe_probe_vf: Failed to enable PCI sriov: -12
ixgbe: 0000:07:00.1: ixgbe_init_interrupt_scheme: Multiqueue Enabled: Rx Queue count = 24, Tx Queue count = 24
ixgbe: 0000:07:00.1: ixgbe_probe: (PCI Express:5.0Gb/s:Width x8) 00:1b:21:6b:bc:92
ixgbe: 0000:07:00.1: ixgbe_probe: MAC: 2, PHY: 0, PBA No: e90209-006
ixgbe: eth1: ixgbe_probe: Intel(R) 10 Gigabit Network Connection

Expected results:
Once the module is loaded as `modprobe ixgbe max_vfs=1` 
A new virtual interface should be created for each physical interface.
Comment 1 Narayanan D 2010-12-23 05:42:36 EST
This issue is raised based on Andy Gospodarek's comments in BZ566027
Comment 2 srinivas gowda 2010-12-23 05:45:02 EST
Created attachment 470399 [details]
dmesg

dmesg
Comment 3 srinivas gowda 2010-12-23 05:45:51 EST
Created attachment 470400 [details]
lspci -vvv

lspci -vvv
Comment 4 srinivas gowda 2010-12-23 05:46:55 EST
Created attachment 470401 [details]
lspci -t

lspci -t
Comment 5 srinivas gowda 2010-12-23 05:48:32 EST
Please find the dmesg (attachment 470399 [details]), lspci -vvv (attachment 470400 [details]) and lspci -t (attachment 470401 [details]) logs attached.
Comment 6 Prarit Bhargava 2011-01-07 10:17:47 EST

*** This bug has been marked as a duplicate of bug 665355 ***
Comment 7 Prarit Bhargava 2011-01-07 14:36:42 EST

*** This bug has been marked as a duplicate of bug 665335 ***
Comment 8 Prarit Bhargava 2011-01-07 14:37:16 EST
Fat fingered the dup BZ #.

Oops.  Sorry about that.

P.

Note You need to log in before you can comment on or make changes to this bug.