Bug 665496 - [6.0] parted command can't create a 1GB partition correctly.
Summary: [6.0] parted command can't create a 1GB partition correctly.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: parted
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED 705163
TreeView+ depends on / blocked
 
Reported: 2010-12-24 03:34 UTC by Masayoshi Yamazaki
Modified: 2018-11-14 19:18 UTC (History)
2 users (show)

Fixed In Version: parted-2.1-14.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:10:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1626 normal SHIPPED_LIVE parted bug fix and enhancement update 2011-12-06 00:50:51 UTC

Comment 2 Hans de Goede 2010-12-24 09:44:29 UTC
I'm no longer the parted maintainer, re-assigning.

Comment 6 Alexander Todorov 2011-08-11 15:08:46 UTC
Reproduced on RHEl 6.1 in KVM guest. Tested on latest 6.2 nightly:

# rpm -q parted 
parted-2.1-14.el6.x86_64

# parted /dev/vdb -s mkpart primary 0 1GB
Warning: The resulting partition is not properly aligned for best performance.

# parted /dev/vdb -s print
Model: Virtio Block Device (virtblk)
Disk /dev/vdb: 10.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End     Size    Type     File system  Flags
 1      512B   1000MB  1000MB  primary

#

Comment 7 errata-xmlrpc 2011-12-06 15:10:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1626.html


Note You need to log in before you can comment on or make changes to this bug.