Bug 665539 - mingw32-bzip2 is missing a static package
Summary: mingw32-bzip2 is missing a static package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw32-bzip2
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-24 15:32 UTC by amorilia
Modified: 2012-05-04 23:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-04 23:07:29 UTC


Attachments (Terms of Use)
add static package to mingw32-bzip2 (1.78 KB, patch)
2010-12-24 15:33 UTC, amorilia
no flags Details | Diff

Description amorilia 2010-12-24 15:32:05 UTC
Description of problem:
Currently, it is not possible to cross compile against bzip2 statically.


Version-Release number of selected component (if applicable):
1.0.5-8


How reproducible:
cat > test.c <<EOF
void main() {};
EOF
i686-pc-mingw32-gcc -Wl,-Bstatic -lbz2 test.c


Steps to Reproduce:
1.
2.
3.
  
Actual results:
/usr/lib64/gcc/i686-pc-mingw32/4.5.0/../../../../i686-pc-mingw32/bin/ld: cannot find -lbz2
collect2: ld returned 1 exit status


Expected results:
The test program compiles successfully.


Additional info:
Patch attached.

Comment 1 amorilia 2010-12-24 15:33:35 UTC
Created attachment 470628 [details]
add static package to mingw32-bzip2

Comment 2 Richard W.M. Jones 2010-12-24 15:47:46 UTC
Amorilia, can you request commit rights for this package, then
you can check the change in yourself.

https://admin.fedoraproject.org/pkgdb/acls/name/mingw32-bzip2

Comment 3 amorilia 2010-12-25 20:44:13 UTC
Sure, thanks for the quick response, and for the display of trust. I happily help out. However, beware that I have no experience with Fedora packaging yet (although I hope to change this). Anyway, I have added myself to the mingw32-bzip2 package. What's the next logical move?

Comment 4 Richard W.M. Jones 2010-12-27 16:32:50 UTC
You need to request 'commit'.

However I realized that maybe you cannot see that button, because
you are not yet a packager.  If that is the case then you also need
to follow this:

http://fedoraproject.org/wiki/PackageMaintainers/Join

If this is too much trouble, then I can commit this, however
it would be better if you could become a packager if you intend
to do any more packaging changes in future.

Comment 5 amorilia 2010-12-28 10:08:13 UTC
Indeed, I am no packager, whence the button withholds. Your latter option makes perfect sense. I will start with reviewing a few packages (suggestions are welcome), and submit a package for mingw32-xz. We will see how it goes from there.

Comment 6 Fedora Update System 2012-04-25 15:58:24 UTC
mingw-bzip2-1.0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mingw-bzip2-1.0.6-1.fc17

Comment 7 Fedora Update System 2012-05-04 22:55:07 UTC
mingw-bzip2-1.0.6-1.fc17, mingw-boost-1.48.0-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.