Bug 665648 - Barry No Longer Syncs With My BlackBerry Bold 9000
Summary: Barry No Longer Syncs With My BlackBerry Bold 9000
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: barry
Version: 14
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christopher D. Stover
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-25 16:43 UTC by Jeffrey D. Yuille
Modified: 2011-02-06 02:15 UTC (History)
4 users (show)

Fixed In Version: barry-0.17-0.6.20110126git.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-04 19:52:30 UTC


Attachments (Terms of Use)

Description Jeffrey D. Yuille 2010-12-25 16:43:47 UTC
Description of problem: During an upgrade about a month ago, Barry was no longer able to backup my BlackBerry.  This is the error message I get: barry cannot connect to Blackberry Bold: -1, error sending control message: Operation not permitted): Probe: GetConfiguration failed. When I upgraded from Fedora 13, all was well but it seems that an upgrade from around November 29, 2010, Barry ceased to function properly. Will there be a fix for this? 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Plug in your BlackBerry (USB)
2.
3.
  
Actual results: Error message appears


Expected results: Should backup your device information


Additional info:

Comment 1 Neil Bryant 2010-12-30 21:00:13 UTC
I, too, have been getting this error on a fresh F14 install. It was reportely fixed some time ago, according to <a href="https://bugzilla.redhat.com/show_bug.cgi?id=542117">bug 542117</a>, but this doesn't appear to be the case.

I 'fixed' it by combining some old reports and:

Writing:
---
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0fca", MODE="0777"
---

to /lib/udev/rules.d/69-blackberry.rules

I tried a couple of other things, but I believe this is what got it working. 10-blackberry.rules exists, and my devices are in it; I made no changes to that.

I'm not sure if this is the proper way to fix it, but I have not yet been able to find a definitive troubleshooting guide for udev (or whatever is current).

hth

Comment 2 Nathanael Noblet 2010-12-31 03:34:03 UTC
Thanks for the report... does btool list the device when run as a user? 

I did an update for barry to fix the usb mode issues someone reported. As there hasn't been a release in awhile we've been using git snapshots. I'm away until later but will see if the main barry developer has any ideas.

Comment 3 Neil Bryant 2010-12-31 07:44:12 UTC
From before I made working changes, I got this:

btool -M :
Bus 001 Device 004: ID 0fca:8004 Research In Motion, Ltd.

I think I had already made the change listed below, but that hadn't fixed things (I was still getting the error). I don't have a lot of notes from before the 'fix'; but if you need anything, I can undo it and see what I can get.

It looks like the USB is set to mode 0664 by 50-udev-default.rules, with owner and group of root, so I only have read access. I presume that's why I could read the info, but not actually make a two-way connect. My first attempt with 69-blackberry.rules was actually:
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0fca", ENV{ACL_MANAGE}="1"
which had no effect. When I changed it to chmod to 0777, that single edit started things working.

Actually, after that Barry threw up a similar error (except -9, rather than -1) but it appears that was just because it didn't ask for the password the first time. I told it to connect again, and it prompted for the password, and connected right up.

and I notice I put the wrong path in, above. The file I added was actually /etc/udev/rules.d/69-blackberry.rules

Comment 4 Fedora Update System 2010-12-31 19:32:09 UTC
barry-0.17-0.6.20101231git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/barry-0.17-0.6.20101231git.fc14

Comment 5 Fedora Update System 2011-01-01 20:21:09 UTC
barry-0.17-0.6.20101231git.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update barry'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/barry-0.17-0.6.20101231git.fc14

Comment 6 Nathanael Noblet 2011-01-03 18:20:44 UTC
So I'm not sure if that helped at all, if so please provide some karma via bodhi, however I didn't see changes with the udev scripts. 

Also, you said you added 69-blackberry.rules it wasn't installed as part of the package?

Comment 7 Nathanael Noblet 2011-01-04 22:27:06 UTC
I think the oddest thing here is that I can still backup and sync

Comment 8 Nathanael Noblet 2011-01-07 03:09:55 UTC
Can you please send in the USB Product ID via lsusb?

Comment 9 freeslkr 2011-01-15 21:38:54 UTC
I still get this error on F14 after upgrading to barry-0.17-0.6.20101231git.fc14. 

To answer your qestion about 69-blackberry.rules, it is installed in /etc/udev/rules.d (not /lib/udev/rules.d, which is the file Neil has added).  The udev docs state that identically named rules in /etc/udev/rules.d over-write those in /lib/udev/rules.d.

As a regular user, `btool -M` shows:

    Usb::Error caught: (-1, error sending control message: Operation 
    not permitted): Probe: GetConfiguration failed

As root, `btool -M` shows:

    Blackberry devices found:
    Device ID: 0x10f1040. PIN: 2579286f, Description: RIM BlackBerry Device
    Using device (PIN): 2579286f
    ContactLdif Mapping:
    <snip>

`lsusb | grep Research`:

    Bus 002 Device 008: ID 0fca:8004 Research In Motion, Ltd.

Following Neil's lead, I edit 69-blackberry.rules to include

    MODE="0770", GROUP="users"

and barrybackup now works as it should.

Comment 10 Jeffrey D. Yuille 2011-01-17 17:00:50 UTC
Well, actually, in the 69-blackberry.rules file, you need to include

MODE="0777", GROUP="users" , instead of MODE="0770", GROUP="users". If you use "0770", Barry will not find you device when you try to connect.

Comment 11 Nathanael Noblet 2011-01-17 20:02:26 UTC
it would if your user account was part of the 'users' group... I'll pass this back upstream to see what they say. The really odd part is that I can still sync on my pearl..

Comment 12 Nathanael Noblet 2011-01-18 06:19:12 UTC
So I think I found the change from F13 to F14 that has caused this to stop working. If you don't mind change the /etc/udev/rules.d/69-blackberry.rules file

to be

ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0fca", ENV{ID_PDA}="1"


and then have udev reload the rules or reboot the system. Please revert any changes to udev rules you may have made. My hunch is that this will temporarily fix it for you. If it does then we know where to go for the permanent fix.

Comment 13 Nathanael Noblet 2011-01-18 16:37:15 UTC
Just as an additional update. in speaking with the udev maintainer this is infact the proper way now for F14. An update will arrive as soon as upstream makes the change...

Comment 14 Fedora Update System 2011-01-19 15:50:17 UTC
barry-0.17-0.6.20110118git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/barry-0.17-0.6.20110118git.fc14

Comment 15 Fedora Update System 2011-01-26 19:29:24 UTC
barry-0.17-0.6.20110126git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/barry-0.17-0.6.20110126git.fc14

Comment 16 Fedora Update System 2011-01-26 19:29:32 UTC
barry-0.17-0.6.20110126git.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/barry-0.17-0.6.20110126git.fc13

Comment 17 Fedora Update System 2011-02-04 19:52:25 UTC
barry-0.17-0.6.20110126git.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-02-04 19:52:56 UTC
barry-0.17-0.6.20110126git.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Neil Bryant 2011-02-06 02:15:10 UTC
Just a happy follow-up:

After receiving the repo notice, I removed my 'fix' file (renamed
/etc/udev/rules.d/69-blackberry.rules); tested:
[...]$ btool -M
Usb::Error caught: (-1, error sending control message: Operation not
permitted): Probe: GetConfiguration failed

Then waited for the update to filter through the repos.

After updating and rebooting:
[...]$ btool -M
Blackberry devices found:
Device ID: 0x1992b10. PIN: 32923ced, Description: RIM BlackBerry Device, Name: 9650 Bold
Using device (PIN): 32923ced
ContactLdif Mapping:
   <snip>

Did a test backup with Barry, and everything worked exactly as it should.

Thank you for taking care of this, and thank everybody for your detailed comments. I've learned a lot from this.

Incidentally, looking back and forth between these two versions:
 barry-0.17-0.6.20101126git.fc14
 barry-0.17-0.6.20110126git.fc14
is a bit of a binary stereogram (those 3-d posters you see in the
malls). If you look at them for a while, eventually the difference
pops out at you... =]


Note You need to log in before you can comment on or make changes to this bug.