Bug 665668 - Entry for 'texinfo' is not included in /usr/share/info/dir
Summary: Entry for 'texinfo' is not included in /usr/share/info/dir
Status: CLOSED DUPLICATE of bug 662382
Alias: None
Product: Fedora
Classification: Fedora
Component: texinfo
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-25 20:34 UTC by Mark Harig
Modified: 2011-01-19 21:08 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-11 14:13:15 UTC


Attachments (Terms of Use)

Description Mark Harig 2010-12-25 20:34:05 UTC
Description of problem:
The Emacs directory file, "/usr/share/info/dir", is not updated when the 'texinfo' RPM package is installed from the Fedora repository.

Version-Release number of selected component (if applicable):
texinfo-4.13a-12.fc14.x86_64

How reproducible:
Every time 'texinfo' is installed using 'yum'/'rpm'.

Steps to Reproduce:
1. Install 'texinfo' using 'yum' directly or the PackageKit applet, 'gpk-application' from the System/Administration menu item, 'Add/Remove Software'.
2. Check for a 'texinfo' entry in /usr/share/info/dir
   $ grep -i texinfo /usr/share/info/dir
  
Actual results:
No entry is listed for 'texinfo' in /usr/share/info/dir

Expected results:
The following lines should be listed in /usr/share/info/dir:
* Texinfo: (texinfo).           The GNU documentation format.
* install-info: (texinfo)Invoking install-info. Update info/dir entries.
* texi2dvi: (texinfo)Format with texi2dvi.      Print Texinfo documents.
* texi2pdf: (texinfo)PDF Output.                PDF output for Texinfo.
* pdftexi2dvi: (texinfo)PDF Output.             PDF output for Texinfo.
* texindex: (texinfo)Format with tex/texindex.  Sort Texinfo index files.
* makeinfo: (texinfo)Invoking makeinfo.         Translate Texinfo source.

Additional info:
It appears that the source of this problem is a small error in the specification for the RPM file for 'texinfo'.  Here are the scripts run for 'texinfo' during installation and un-installation:

rpm -q --scripts texinfo
postinstall scriptlet (using /bin/sh):
if [ -f /usr/share/info/texinfo ]; then # --excludedocs?
    /sbin/install-info /usr/share/info/texinfo /usr/share/info/dir || :
fi
preuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ]; then
    if [ -f /usr/share/info/texinfo ]; then # --excludedocs?
        /sbin/install-info --delete /usr/share/info/texinfo /usr/share/info/dir || :
    fi
fi

Note that the file checked for is /usr/share/info/texinfo.  However, the documentation files included in the 'texinfo' package are compressed:

$ rpm -qd texinfo | grep /usr/share/info
/usr/share/info/texinfo-1.gz
/usr/share/info/texinfo-2.gz
/usr/share/info/texinfo-3.gz
/usr/share/info/texinfo.gz

In the scripts, above, '/usr/share/info/texinfo' should be replaced with '/usr/share/info/texinfo.gz'.

Comment 1 Vitezslav Crhonek 2011-01-11 14:13:15 UTC

*** This bug has been marked as a duplicate of bug 662382 ***

Comment 2 Fedora Update System 2011-01-11 14:25:57 UTC
texinfo-4.13a-13.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/texinfo-4.13a-13.fc14

Comment 3 Fedora Update System 2011-01-19 21:08:13 UTC
texinfo-4.13a-13.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.